summaryrefslogtreecommitdiff
path: root/sys-fs/quota/quota-4.09.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
commit7f740fcb9a0165d81bfecf7fb5da647763d76a1b (patch)
tree45dab58d8bd40ef97234398e9e1850495ea60273 /sys-fs/quota/quota-4.09.ebuild
parent0bf5c5a0b1ff93d1f4aaa8cdea6acda5e42c2068 (diff)
gentoo auto-resync : 23:09:2022 - 05:29:13
Diffstat (limited to 'sys-fs/quota/quota-4.09.ebuild')
-rw-r--r--sys-fs/quota/quota-4.09.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/sys-fs/quota/quota-4.09.ebuild b/sys-fs/quota/quota-4.09.ebuild
new file mode 100644
index 000000000000..2c2297f50915
--- /dev/null
+++ b/sys-fs/quota/quota-4.09.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="
+ sys-fs/e2fsprogs
+ ldap? ( >=net-nds/openldap-2.3.35:= )
+ netlink? (
+ sys-apps/dbus
+ dev-libs/libnl:3
+ )
+ rpc? (
+ elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
+ net-libs/libtirpc:=
+ net-libs/rpcsvc-proto
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+PDEPEND="rpc? ( net-nds/rpcbind )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.09-configure-bashism.patch
+ "${FILESDIR}"/${PN}-4.09-gettext-version.patch
+)
+
+src_prepare() {
+ default
+
+ # Only needed for bashism patch and stale macros patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-ext2direct
+ $(use_enable nls)
+ $(use_enable ldap ldapmail)
+ $(use_enable netlink)
+ $(use_enable rpc)
+ $(use_enable rpc rpcsetquota)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/* README.* Changelog
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins "${FILESDIR}"/ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe "${FILESDIR}"/ldap-scripts/*.pl
+ doexe "${FILESDIR}"/ldap-scripts/edquota_editor
+ fi
+}