summaryrefslogtreecommitdiff
path: root/sys-fs/safecopy/safecopy-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /sys-fs/safecopy/safecopy-1.7-r1.ebuild
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'sys-fs/safecopy/safecopy-1.7-r1.ebuild')
-rw-r--r--sys-fs/safecopy/safecopy-1.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/safecopy/safecopy-1.7-r1.ebuild b/sys-fs/safecopy/safecopy-1.7-r1.ebuild
new file mode 100644
index 000000000000..9991c27a9c67
--- /dev/null
+++ b/sys-fs/safecopy/safecopy-1.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tool for fault-tolerant data recovery from damaged (IO-errors) devices or files"
+HOMEPAGE="https://safecopy.sourceforge.net"
+SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${PN}-tests.patch )
+DOCS=( README )
+
+src_configure() {
+ econf
+ cd simulator || die
+ use test && econf
+}
+
+src_compile() {
+ emake
+ use test && emake -C simulator
+}
+
+src_test() {
+ cd test || die
+ ./test.sh || die
+}