summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild')
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
index b77878296fdf..22a2dbc93b62 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
@@ -13,9 +13,9 @@ else
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi
-LICENSE="GPL-3+"
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
SLOT="0"
-IUSE="lz4 lzo selinux +xz zstd"
+IUSE="lz4 lzo selinux +tools +xz zstd"
DEPEND="
sys-libs/zlib:=
@@ -34,11 +34,18 @@ src_prepare() {
src_configure() {
local myconf=(
+ --disable-static
$(use_with lz4)
$(use_with lzo)
$(use_with selinux)
+ $(use_with tools)
$(use_with xz)
$(use_with zstd)
)
econf "${myconf[@]}"
}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}