summaryrefslogtreecommitdiff
path: root/sys-fs/static-dev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
commit704343381e435b306648a2d85a77a58e34478643 (patch)
tree009e24c29e03885a4bd7bb17b673f62567395237 /sys-fs/static-dev
parenteb147001d2176fe9850e42017a6b1284baf865ff (diff)
gentoo auto-resync : 29:10:2023 - 09:35:42
Diffstat (limited to 'sys-fs/static-dev')
-rw-r--r--sys-fs/static-dev/Manifest1
-rw-r--r--sys-fs/static-dev/static-dev-0.1-r3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/static-dev/Manifest b/sys-fs/static-dev/Manifest
index 365f95fabe48..c8517abda212 100644
--- a/sys-fs/static-dev/Manifest
+++ b/sys-fs/static-dev/Manifest
@@ -1,2 +1,3 @@
EBUILD static-dev-0.1-r2.ebuild 1105 BLAKE2B 9e650825bfb3cbf7758ece6ab9422c7c3bad3755bc19500499ac07ae65f604185b2c18e54ced1dba36e4c795eb6dede328e1db7735d2b229aa37463eb1ec8a32 SHA512 a023956ddfdd4fd9d90f9e8d6ffd17dd7f58be8d575e71f7ba6a530aa4e7402c0c4d6af0bb04936b7b5e651202c3ff838ce417ff76f6f01fb73118806b747282
+EBUILD static-dev-0.1-r3.ebuild 1111 BLAKE2B 062b6509fe115b3fa448b22d1edb4656bc61813aa26c5dec379a411f48ee90ac688080526cf1efc2d8da1c84ae18712867acef567e8a87b755bc6653261679de SHA512 1fa6e21d3b38b3fcf900c33da92ff4075c1d9b6bcdb8bd87821abc138081cf0d22c4eb9115572e063e97d6b0069f69a3d3d9a01c339485048096e04dc5e88036
MISC metadata.xml 254 BLAKE2B f3a9f843cf94243d1129711770df727fcdc8808bca829ef784819cab6f5410dfa463cfed85182f8228c7de796a674dd602653ad3ef817a62c0c3e7198b23befe SHA512 b9fcd3084a7e197f6138e1ce8b0eff99c4c203c37a7d5c40de207040ba1501ef0e5b2f4e00216a567037bcd6d3394fdec6ff587484c9ba2fca9d04f431733b7c
diff --git a/sys-fs/static-dev/static-dev-0.1-r3.ebuild b/sys-fs/static-dev/static-dev-0.1-r3.ebuild
new file mode 100644
index 000000000000..0be25176d6fc
--- /dev/null
+++ b/sys-fs/static-dev/static-dev-0.1-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A skeleton, statically managed /dev"
+HOMEPAGE="https://bugs.gentoo.org/107875"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IDEPEND="sys-apps/makedev"
+
+pkg_pretend() {
+ bailout() {
+ eerror "We have detected that you currently use udev or devfs or devtmpfs"
+ eerror "and this ebuild cannot install to the same mount-point."
+ die "Cannot install on udev/devfs tmpfs."
+ }
+
+ if [[ ${MERGE_TYPE} == "buildonly" ]] ; then
+ # User is just compiling which is fine -- all our checks are merge-time.
+ return
+ fi
+
+ # We want to not clobber udev (tmpfs) or older devfs setups.
+ if [[ -d ${ROOT}/dev/.udev || -c ${ROOT}/dev/.devfs ]] ; then
+ bailout
+ fi
+
+ # We also want to not clobber newer devtmpfs setups.
+ if [[ -z ${ROOT} ]] && \
+ ! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then
+ bailout
+ fi
+}
+
+pkg_postinst() {
+ MAKEDEV -d "${ROOT}"/dev generic sg scd rtc hde hdf hdg hdh input audio video
+}