summaryrefslogtreecommitdiff
path: root/sys-fs/static-dev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-27 20:54:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-27 20:54:43 +0100
commitdab4468820bf30b5a0764b19f519006f0e6bb371 (patch)
tree81b0d4daac1676804b504ed5c49a833b334d1024 /sys-fs/static-dev
parentd654bb059f90c086625a31ce15747f8418cd4bd5 (diff)
gentoo auto-resync : 27:08:2022 - 20:54:42
Diffstat (limited to 'sys-fs/static-dev')
-rw-r--r--sys-fs/static-dev/Manifest2
-rw-r--r--sys-fs/static-dev/static-dev-0.1-r2.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/sys-fs/static-dev/Manifest b/sys-fs/static-dev/Manifest
index 660dbc92fa5a..365f95fabe48 100644
--- a/sys-fs/static-dev/Manifest
+++ b/sys-fs/static-dev/Manifest
@@ -1,2 +1,2 @@
-EBUILD static-dev-0.1-r2.ebuild 1099 BLAKE2B 961b2608f87573543f6288936b43ae68ed054f1cf68e0bf8031c38dffae4436e76202776ad750bc2ed2ed48ddaaddc78b9accbcb165ac6696d36bfe8f9ed9408 SHA512 b436183c35aaf1a0e91bd254f3dbc407adb5b4d8d91a784ba173f65d1187bf092a798cabf679e07266af0e4de67cbff6b49bef336d316f5b40bea49763df69a0
+EBUILD static-dev-0.1-r2.ebuild 1105 BLAKE2B 9e650825bfb3cbf7758ece6ab9422c7c3bad3755bc19500499ac07ae65f604185b2c18e54ced1dba36e4c795eb6dede328e1db7735d2b229aa37463eb1ec8a32 SHA512 a023956ddfdd4fd9d90f9e8d6ffd17dd7f58be8d575e71f7ba6a530aa4e7402c0c4d6af0bb04936b7b5e651202c3ff838ce417ff76f6f01fb73118806b747282
MISC metadata.xml 254 BLAKE2B f3a9f843cf94243d1129711770df727fcdc8808bca829ef784819cab6f5410dfa463cfed85182f8228c7de796a674dd602653ad3ef817a62c0c3e7198b23befe SHA512 b9fcd3084a7e197f6138e1ce8b0eff99c4c203c37a7d5c40de207040ba1501ef0e5b2f4e00216a567037bcd6d3394fdec6ff587484c9ba2fca9d04f431733b7c
diff --git a/sys-fs/static-dev/static-dev-0.1-r2.ebuild b/sys-fs/static-dev/static-dev-0.1-r2.ebuild
index ca46b76ab1e5..c915e4e6bc45 100644
--- a/sys-fs/static-dev/static-dev-0.1-r2.ebuild
+++ b/sys-fs/static-dev/static-dev-0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
RDEPEND="sys-apps/makedev"
pkg_pretend() {
- abort() {
+ bailout() {
eerror "We have detected that you currently use udev or devfs or devtmpfs"
eerror "and this ebuild cannot install to the same mount-point."
die "Cannot install on udev/devfs tmpfs."
@@ -26,13 +26,13 @@ pkg_pretend() {
# We want to not clobber udev (tmpfs) or older devfs setups.
if [[ -d ${ROOT}/dev/.udev || -c ${ROOT}/dev/.devfs ]] ; then
- abort
+ bailout
fi
# We also want to not clobber newer devtmpfs setups.
if [[ -z ${ROOT} ]] && \
! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then
- abort
+ bailout
fi
}