summaryrefslogtreecommitdiff
path: root/sys-fs/vzquota/vzquota-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/vzquota/vzquota-3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/vzquota/vzquota-3.1.ebuild')
-rw-r--r--sys-fs/vzquota/vzquota-3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/vzquota/vzquota-3.1.ebuild b/sys-fs/vzquota/vzquota-3.1.ebuild
new file mode 100644
index 000000000000..342d9e6b24ef
--- /dev/null
+++ b/sys-fs/vzquota/vzquota-3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenVZ VPS disk quota utility"
+HOMEPAGE="http://openvz.org/download/utils/vzquota/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc64 ~sparc x86"
+IUSE=""
+
+src_prepare() {
+ sed -e 's,$(INSTALL) -s -m,$(INSTALL) -m,' \
+ -e 's:$(CC) $(CFLAGS) -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' \
+ -e 's:-Werror ::' \
+ -i "${S}/src/Makefile" || die 'sed on src/Makefile failed'
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" INSTALL="${EPREFIX}/usr/bin/install" install
+ keepdir /var/vzquota
+ # remove accidentally created man8 dir
+ rm -r "${ED}/man8" || die 'remove man8 directory failed'
+}