summaryrefslogtreecommitdiff
path: root/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild29
1 files changed, 5 insertions, 24 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild b/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
index e13414de1dad..70e095eb507f 100644
--- a/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,21 +11,16 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86"
-IUSE="icu libedit nls readline static static-libs"
-REQUIRED_USE="static? ( static-libs )"
+KEYWORDS="alpha amd64 ~arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sh ~sparc x86"
+IUSE="icu libedit nls readline static-libs"
LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
icu? ( dev-libs/icu:=[static-libs(+)] )
readline? ( sys-libs/readline:0=[static-libs(+)] )
!readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+RDEPEND="${LIB_DEPEND//\[static-libs(+)]}
!<sys-fs/xfsdump-3"
DEPEND="${RDEPEND}
- static? (
- ${LIB_DEPEND}
- readline? ( sys-libs/ncurses:0=[static-libs] )
- )
nls? ( sys-devel/gettext )"
PATCHES=(
@@ -44,22 +39,12 @@ pkg_setup() {
src_prepare() {
default
- # LLDFLAGS is used for programs, so apply -all-static when USE=static is enabled.
# Clear out -static from all flags since we want to link against dynamic xfs libs.
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- -e "1iLLDFLAGS += $(usex static '-all-static' '')" \
include/builddefs.in || die
find -name Makefile -exec \
sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
-
- # TODO: Write a patch for configure.ac to use pkg-config for the uuid-part.
- if use static && use readline ; then
- sed -i \
- -e 's|-lreadline|& -lncurses|' \
- -e 's|-lblkid|& -luuid|' \
- configure || die
- fi
}
src_configure() {
@@ -76,12 +61,8 @@ src_configure() {
$(use_enable nls gettext)
$(use_enable readline)
$(usex readline --disable-editline $(use_enable libedit editline))
+ $(use_enable static-libs static)
)
- if use static || use static-libs ; then
- myconf+=( --enable-static )
- else
- myconf+=( --disable-static )
- fi
econf "${myconf[@]}"