summaryrefslogtreecommitdiff
path: root/sys-fs/zfs-kmod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /sys-fs/zfs-kmod
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'sys-fs/zfs-kmod')
-rw-r--r--sys-fs/zfs-kmod/Manifest1
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.7.9999.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/sys-fs/zfs-kmod/Manifest b/sys-fs/zfs-kmod/Manifest
index 8f7f4c772015..72792cb80444 100644
--- a/sys-fs/zfs-kmod/Manifest
+++ b/sys-fs/zfs-kmod/Manifest
@@ -7,5 +7,6 @@ EBUILD zfs-kmod-0.6.5.11.ebuild 4075 BLAKE2B a1b642691217beee71f20c29932e2de6b65
EBUILD zfs-kmod-0.6.5.4-r1.ebuild 4401 BLAKE2B a4648117230b7351ad427a7d93d704162eab8561b048730e28224594f2653e2a975da34e66a59de007c61187beb504cc8e263942602f141c7afee75cb670a43f SHA512 589e0c952efe6bc9d2fe0b1a85c0309eefa64a3c632f5030112b613d3c2d2c177a8fd7b501b0296ed74e040e3a574296c5acf86701925154377bf479b8d3aaad
EBUILD zfs-kmod-0.7.5.ebuild 4075 BLAKE2B 0b96f439ca7245cac88595998a3781f54a1651e4352ec71e61ad9292a771cf642a056294492b12f9a2fd6a77a4ff1ea589713e2b83e03660691dda894f66f5df SHA512 376b3c08104d7722c240617c377cb9c87c6e0cacf401107b26fdd54c121d36d53fded91c2279a4471eb4629429133a550ba6beb990805ba9e109d765a33d8215
EBUILD zfs-kmod-0.7.6.ebuild 4054 BLAKE2B d9696df2d2a3612b42d426afb40f588f47a53e7d821ea14cd71c3a0edcdb2663195bdfd8e2a5d18b05d230e78194bef2a459be912f8e5327bf589a35cd548e89 SHA512 ac7ea69f470ab7b8749abd815069f600aa045f45f634166f65edc76849e05a6ceff014d50df860991de7a7bae3386fd42fa3765f3e0e94939550260386df2b9c
+EBUILD zfs-kmod-0.7.9999.ebuild 4133 BLAKE2B e4863fb198b74a1ba2417caca7d1d817d23423b8d8c1da2d65d422bb9c25e59ed6aff0fc15f7037529e491dee71f06b05252cc7305a9ae4b7383969692977f80 SHA512 2ae7acae2a3f4f8836dcbbe2e30773f966204e568bf4754fd0d7225052508ab9b0f90c8eab0974b1436472642cacf652da6e1db2216771f58c962a0f9a6a06a7
EBUILD zfs-kmod-9999.ebuild 4092 BLAKE2B 9aff1a1edb78f8c445ae022c153cf8c8afd524c97e47542f74b11f6248642a638f81c03a6403376b6d92c51512abd9238806c81eec33acc52dc682706fd5191e SHA512 f8d8674dd7ff3692735f242c3634671a617ae0e2de6530dc380ea58292f9a6c9d5829f4b0548e677471224b2fe9796ba11ee069d2bf66bb5f9611a3acbcd4b2e
MISC metadata.xml 554 BLAKE2B 3f2673ca745f69a68210ee7e14ef93037285807fb174aad38913c9478ce4f38459cb000ad46f9b6b37a62f3f13287fba9f646bdf55a3c6126704082ecb6294e6 SHA512 c5dbcf5b795510abbe6c6dbea53ea6b9a438f0b2b8f7af28ae3ec9d8816d51c6ee22938bfe7d222d5b451065b57447064fba59e93a9621f1132e3d27ef8d385b
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.7.9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.7.9999.ebuild
new file mode 100644
index 000000000000..8a1354857fe4
--- /dev/null
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.7.9999.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+if [[ ${PV} == *"9999" ]] ; then
+ AUTOTOOLS_AUTORECONF="1"
+ EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+ EGIT_BRANCH="zfs-0.7-release"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/zfs-${PV}.tar.gz"
+ S="${WORKDIR}/zfs-${PV}"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+fi
+
+inherit flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils
+
+DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="CDDL debug? ( GPL-2+ )"
+SLOT="0"
+IUSE="custom-cflags debug +rootfs"
+RESTRICT="debug? ( strip ) test"
+
+DEPEND="
+ =sys-kernel/spl-${PV}*
+ dev-lang/perl
+ virtual/awk
+"
+
+RDEPEND="${DEPEND}
+ !sys-fs/zfs-fuse
+"
+
+AT_M4DIR="config"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+DOCS=( AUTHORS COPYRIGHT DISCLAIMER README.markdown )
+
+pkg_setup() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="
+ !DEBUG_LOCK_ALLOC
+ !CONFIG_REISER4_FS
+ EFI_PARTITION
+ IOSCHED_NOOP
+ MODULES
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ use debug && CONFIG_CHECK="${CONFIG_CHECK}
+ FRAME_POINTER
+ DEBUG_INFO
+ !DEBUG_INFO_REDUCED
+ "
+
+ use rootfs && \
+ CONFIG_CHECK="${CONFIG_CHECK}
+ BLK_DEV_INITRD
+ DEVTMPFS
+ "
+
+ kernel_is ge 2 6 32 || die "Linux 2.6.32 or newer required"
+
+ [[ ${PV} != *"9999" ]] && \
+ { kernel_is le 4 15 || die "Linux 4.15 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ # Remove GPLv2-licensed ZPIOS unless we are debugging
+ use debug || sed -e 's/^subdir-m += zpios$//' -i "${S}/module/Makefile.in"
+
+ # Set module revision number
+ [[ ${PV} != *"9999" ]] && \
+ { sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" "${S}/META" || die "Could not set Gentoo release"; }
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local SPL_PATH="$(basename $(echo "${EROOT}usr/src/spl-"*))"
+ use custom-cflags || strip-flags
+ filter-ldflags -Wl,*
+
+ set_arch_to_kernel
+ local myeconfargs=(${myeconfargs}
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=kernel
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ --with-spl="${EROOT}usr/src/${SPL_PATH}"
+ --with-spl-obj="${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ # Remove old modules
+ if [ -d "${EROOT}lib/modules/${KV_FULL}/addon/zfs" ]
+ then
+ ewarn "${PN} now installs modules in ${EROOT}lib/modules/${KV_FULL}/extra/zfs"
+ ewarn "Old modules were detected in ${EROOT}lib/modules/${KV_FULL}/addon/zfs"
+ ewarn "Automatically removing old modules to avoid problems."
+ rm -r "${EROOT}lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
+ rmdir --ignore-fail-on-non-empty "${EROOT}lib/modules/${KV_FULL}/addon"
+ fi
+
+ if use x86 || use arm
+ then
+ ewarn "32-bit kernels will likely require increasing vmalloc to"
+ ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
+ fi
+
+ ewarn "This version of ZFSOnLinux includes support for new feature flags"
+ ewarn "that are incompatible with previous versions. GRUB2 support for"
+ ewarn "/boot with the new feature flags is not yet available."
+ ewarn "Do *NOT* upgrade root pools to use the new feature flags."
+ ewarn "Any new pools will be created with the new feature flags by default"
+ ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
+ ewarn "create a newpool that is backward compatible wih GRUB2, use "
+ ewarn
+ ewarn "zpool create -d -o feature@async_destroy=enabled "
+ ewarn " -o feature@empty_bpobj=enabled -o feature@lz4_compress=enabled"
+ ewarn " -o feature@spacemap_histogram=enabled"
+ ewarn " -o feature@enabled_txg=enabled "
+ ewarn " -o feature@extensible_dataset=enabled -o feature@bookmarks=enabled"
+ ewarn " ..."
+ ewarn
+ ewarn "GRUB2 support will be updated as soon as either the GRUB2"
+ ewarn "developers do a tag or the Gentoo developers find time to backport"
+ ewarn "support from GRUB2 HEAD."
+}