summaryrefslogtreecommitdiff
path: root/sys-kernel/cryptodev/cryptodev-1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-kernel/cryptodev/cryptodev-1.11.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-kernel/cryptodev/cryptodev-1.11.ebuild')
-rw-r--r--sys-kernel/cryptodev/cryptodev-1.11.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/cryptodev/cryptodev-1.11.ebuild b/sys-kernel/cryptodev/cryptodev-1.11.ebuild
new file mode 100644
index 000000000000..08cf07fc623e
--- /dev/null
+++ b/sys-kernel/cryptodev/cryptodev-1.11.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="device that allows access to Linux kernel cryptographic drivers"
+HOMEPAGE="http://cryptodev-linux.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cryptodev-linux/cryptodev-linux.git"
+ S="${WORKDIR}/${PN}-${PV}"
+else
+ SRC_URI="https://github.com/cryptodev-linux/cryptodev-linux/archive/${PN}-linux-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${PN}-linux-${PN}-linux-${PV}
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/linux-sources"
+
+#test requires that the module is already loaded
+RESTRICT="test"
+
+MODULE_NAMES="cryptodev(extra:${S})"
+BUILD_PARAMS="KERNEL_DIR=\"\${KV_OUT_DIR}\""
+BUILD_TARGETS="build"
+
+pkg_pretend() {
+ use kernel_linux || die "cryptodev ebuild only support linux"
+
+ CONFIG_CHECK="~CRYPTO ~CRYPTO_AEAD"
+ if kernel_is -lt 4 8 0; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_BLKCIPHER"
+ else
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_SKCIPHER"
+ fi
+ check_extra_config
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /usr/include/crypto
+ doins crypto/cryptodev.h
+
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+}