summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut-crypt-ssh/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-kernel/dracut-crypt-ssh/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-kernel/dracut-crypt-ssh/files')
-rw-r--r--sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-makefile.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-makefile.patch b/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-makefile.patch
new file mode 100644
index 000000000000..d45bc41ed60a
--- /dev/null
+++ b/sys-kernel/dracut-crypt-ssh/files/dracut-crypt-ssh-1.0.7-makefile.patch
@@ -0,0 +1,19 @@
+# https://bugs.gentoo.org/726014
+# https://bugs.gentoo.org/781125
+--- a/modules/60crypt-ssh/helper/Makefile
++++ b/modules/60crypt-ssh/helper/Makefile
+@@ -17,11 +17,11 @@ clean:
+ rm -f *.o console_auth unlock crypttab-test
+
+ console_auth: auth.c
+- $(CC) $(CFLAGS) $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -o $@
+
+ unlock: crypttab.o unlock.o
+- $(CC) $(CFLAGS) -lblkid $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -lblkid -o $@
+
+ crypttab-test: crypttab-test.c crypttab.o crypttab-test-data
+- $(CC) crypttab-test.c $(CFLAGS) crypttab.o -lblkid -o crypttab-test
++ $(CC) crypttab-test.c $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) crypttab.o -lblkid -o crypttab-test
+ ./crypttab-test