summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild')
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild
deleted file mode 100644
index 4d3cb4225691..000000000000
--- a/sys-kernel/gentoo-kernel/gentoo-kernel-5.7.12.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit kernel-build
-
-MY_P=linux-${PV%.*}
-GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 1 ))
-# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
-CONFIG_VER=5.7.8
-CONFIG_HASH=14d239184a721485a823f30f5aede1c6190558ad
-
-DESCRIPTION="Linux kernel built with Gentoo patches"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
- https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.base.tar.xz
- https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.extras.tar.xz
- amd64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
- -> kernel-x86_64-fedora.config.${CONFIG_VER}
- )
- arm64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
- -> kernel-aarch64.config.${CONFIG_VER}
- )
- x86? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
- -> kernel-i686-fedora.config.${CONFIG_VER}
- )"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="debug"
-REQUIRED_USE="
- arm? ( savedconfig )"
-
-RDEPEND="
- !sys-kernel/vanilla-kernel:${SLOT}
- !sys-kernel/vanilla-kernel-bin:${SLOT}"
-BDEPEND="
- debug? ( dev-util/dwarves )"
-
-pkg_pretend() {
- ewarn "Starting with 5.7.9, Distribution Kernels are switching from Arch"
- ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
-
- kernel-install_pkg_pretend
-}
-
-src_prepare() {
- local PATCHES=(
- # meh, genpatches have no directory
- "${WORKDIR}"/*.patch
- )
- default
-
- # prepare the default config
- case ${ARCH} in
- amd64)
- cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
- ;;
- arm)
- return
- ;;
- arm64)
- cp "${DISTDIR}/kernel-aarch64.config.${CONFIG_VER}" .config || die
- ;;
- x86)
- cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
- ;;
- *)
- die "Unsupported arch ${ARCH}"
- ;;
- esac
-
- local config_tweaks=(
- # shove arch under the carpet!
- -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
- # we do support x32
- -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
- # disable signatures
- -e '/CONFIG_MODULE_SIG/d'
- -e '/CONFIG_SECURITY_LOCKDOWN/d'
- )
- use debug || config_tweaks+=(
- -e '/CONFIG_DEBUG_INFO/d'
- )
- sed -i "${config_tweaks[@]}" .config || die
-}