summaryrefslogtreecommitdiff
path: root/sys-kernel/installkernel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
commit4c5bd80830992553e02f099442277e10ee97372d (patch)
treebeeb8ff1f9d6f5b48418cc2134cec247aaade4e4 /sys-kernel/installkernel
parentdb653baf275126269bb89ea0d2bdb8e50497a94c (diff)
gentoo auto-resync : 22:02:2025 - 00:16:22
Diffstat (limited to 'sys-kernel/installkernel')
-rw-r--r--sys-kernel/installkernel/Manifest2
-rw-r--r--sys-kernel/installkernel/installkernel-54.ebuild236
2 files changed, 238 insertions, 0 deletions
diff --git a/sys-kernel/installkernel/Manifest b/sys-kernel/installkernel/Manifest
index 740521d082d3..a5a4ceef8433 100644
--- a/sys-kernel/installkernel/Manifest
+++ b/sys-kernel/installkernel/Manifest
@@ -1,5 +1,7 @@
DIST installkernel-50.tar.gz 25265 BLAKE2B 12fe64bc584d7ead4a24a7d81b83c69fb0aad21fb0f88195e5608519ade5dbf9e6009b6b6d0f81190b96cf170b6b5e7f220522bded20d99fa95b3fe65e8476a6 SHA512 fb780d7e0c724e93c2c0a0f43fc17a95862a55733ad76df43daab3ce09f4d06e2c357a0bac0decd821c9c36dbda846cf89f8cc60d721f0cb32b39f336da2c72c
DIST installkernel-53.tar.gz 25519 BLAKE2B cb8eec9984ad151849fcdbf820c4e5d98c58b1a418303de9de854c2fb1a11494e759d15da11a91c035a512f4f88a47ffc0fda21202aa37fb8237e66cd2c9e3b2 SHA512 4f1e10bb5a4fd2aa5f4421f991c73774c087f1e4371573de92153b0d92b49a5964b801828ee47663256a90b15fa013e6650761d36ba6c4f0c978bf70cfe3990c
+DIST installkernel-54.tar.gz 28596 BLAKE2B 5415dcca211af776069d98f259e81a4419fda1ad7a1754aefd11985f8f737574a08cc4367f311ca17dda757a4e3ed1eb9102a23eb3868146815cb8e0cfb8f451 SHA512 05b20c9b96a98cdbcd16fe7c4ff6ed03ac6df32455198d5aeb9cb49aaffe677ec971481389c17f060158a3c9764c9fb3c0312771ed1c34190f0d5c97abc4db7a
EBUILD installkernel-50.ebuild 7400 BLAKE2B 59bc011dc19fa29027d4f511d0a86c14060a5a119ccd5941b680bb153fac484128bcf2a8f1ae4ef7221ea0491c9e21ec949c860871daa260bf779af496d06764 SHA512 78d7899e8b40029654225a2a21663ba68a54e534499b3d8ccc1acba2b501905604e2a5125cf0065a98b5ba2dbb26b13a107cac9ac97394e2d4bd98ced94fad31
EBUILD installkernel-53.ebuild 7325 BLAKE2B 48139bf4791462256d7f4b38083556af6fcfa6abf49a077e7bed32c61788be08ba8dce35c62da363cd0756eec1da89a2ed9d7b38de0ca6a5db9716b18af8ff2d SHA512 0704f0ab4d652f940a2aa1a6651524ef3beff8083d055591236a40a9e5459bba80cd72bcc2c3cc34d222aaec060f507bfa9a86b8e213f7fb167fe4a4e22a91a0
+EBUILD installkernel-54.ebuild 7035 BLAKE2B fbf71e282efa16ca8d49f1095069d971f1924ab5d50cdb75822a1b6fac0cb2a6ef234854101706435545dc2781c0e76663c4cdc606fca8a6c577dacbf99a3a08 SHA512 3df71bf31e5566975b40a2839191b4db9ef8f392edc6887978a23ed2964da70d7a4caa3eb466df440b45a7c3ac6450821455f470b07f900f960db79f557c4c8b
MISC metadata.xml 1379 BLAKE2B c141302cfe1dddf7d11d68cafdf97437f037caab171b1c1b071cc366b6a98acb5940c1ab73bcc49bf97fe9c852ad28c8923fbf00f0a51f2a02174a5d542f9edf SHA512 f5a20936b0b569fd2a8eadb76eeb8d7ec8c905b0e15ae285c351d82bef0c001e64d47a19774a6b958b845a20adc3df5e7cc583649dfcf9ef7c684132498e8bf8
diff --git a/sys-kernel/installkernel/installkernel-54.ebuild b/sys-kernel/installkernel/installkernel-54.ebuild
new file mode 100644
index 000000000000..76e844e55163
--- /dev/null
+++ b/sys-kernel/installkernel/installkernel-54.ebuild
@@ -0,0 +1,236 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit eapi9-ver linux-info
+
+DESCRIPTION="Gentoo fork of installkernel script from debianutils"
+HOMEPAGE="
+ https://github.com/projg2/installkernel-gentoo
+ https://wiki.gentoo.org/wiki/Installkernel
+"
+SRC_URI="https://github.com/projg2/installkernel-gentoo/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dracut efistub grub refind systemd systemd-boot ugrd uki ukify"
+REQUIRED_USE="
+ systemd-boot? ( systemd )
+ ukify? ( uki )
+ ?? ( dracut ugrd )
+"
+# systemd-boot could be made to work without the systemd flag, but this
+# makes no sense since in systemd(-utils) the boot flag already
+# requires the kernel-install flag.
+#
+# Ukify hooks do nothing if the layout is not uki, so force this here.
+#
+# Only one initramfs generator flag can be selected. Note that while
+# both dracut and ukify are UKI generators we don't block those because
+# enabling both results in building an initramfs only with dracut and
+# building an UKI with ukify, which is a valid configuration.
+
+RDEPEND="
+ !<=sys-kernel/installkernel-systemd-3
+ dracut? (
+ >=sys-kernel/dracut-106
+ uki? (
+ || (
+ sys-apps/systemd[boot(-)]
+ sys-apps/systemd-utils[boot(-)]
+ )
+ )
+ )
+ efistub? (
+ systemd? ( >=app-emulation/virt-firmware-24.7 )
+ !systemd? ( sys-boot/uefi-mkconfig )
+ )
+ grub? ( sys-boot/grub )
+ refind? ( sys-boot/refind )
+ systemd? (
+ || (
+ sys-apps/systemd[kernel-install(-)]
+ sys-apps/systemd-utils[kernel-install(-)]
+ )
+ )
+ systemd-boot? (
+ || (
+ sys-apps/systemd[boot(-)]
+ sys-apps/systemd-utils[boot(-)]
+ )
+ )
+ ukify? (
+ || (
+ sys-apps/systemd[boot(-),ukify(-)]
+ sys-apps/systemd-utils[boot(-),ukify(-)]
+ )
+ )
+ ugrd? ( >=sys-kernel/ugrd-1.31.2 )
+ !=sys-apps/systemd-255.2-r1
+ !=sys-apps/systemd-255.2-r0
+ !~sys-apps/systemd-255.1
+ !~sys-apps/systemd-255.0
+ !=sys-apps/systemd-254.8-r0
+ !=sys-apps/systemd-254.7-r0
+ !~sys-apps/systemd-254.6
+ !<=sys-apps/systemd-254.5-r1
+" # Block against systemd that still installs dummy install.conf
+
+pkg_setup() {
+ use efistub && CONFIG_CHECK="~EFI_STUB" linux-info_pkg_setup
+}
+
+src_install() {
+ keepdir /etc/kernel/install.d
+ keepdir /etc/kernel/preinst.d
+ keepdir /etc/kernel/postinst.d
+ keepdir /usr/lib/kernel/install.d
+ keepdir /usr/lib/kernel/preinst.d
+ keepdir /usr/lib/kernel/postinst.d
+
+ exeinto /usr/lib/kernel/preinst.d
+ doexe hooks/99-check-diskspace.install
+ use dracut && doexe hooks/50-dracut.install
+ use ukify && doexe hooks/60-ukify.install
+
+ exeinto /usr/lib/kernel/postinst.d
+ doexe hooks/99-write-log.install
+ use grub && doexe hooks/91-grub-mkconfig.install
+ use efistub && doexe hooks/95-efistub-uefi-mkconfig.install
+ use refind && doexe hooks/95-refind-copy-icon.install
+
+ exeinto /usr/lib/kernel/install.d
+ doexe hooks/systemd/00-00machineid-directory.install
+ doexe hooks/systemd/10-copy-prebuilt.install
+ doexe hooks/systemd/85-check-diskspace.install
+ doexe hooks/systemd/90-compat.install
+ doexe hooks/systemd/90-zz-update-static.install
+ doexe hooks/systemd/99-write-log.install
+ use grub && doexe hooks/systemd/91-grub-mkconfig.install
+ use efistub && doexe hooks/systemd/95-efistub-kernel-bootcfg.install
+ use refind && doexe hooks/systemd/95-refind-copy-icon.install
+
+ if use grub && use uki; then
+ exeinto /etc/grub.d
+ doexe grub/05_uki
+ fi
+
+ if use systemd; then
+ sed -e 's/${SYSTEMD_KERNEL_INSTALL:=0}/${SYSTEMD_KERNEL_INSTALL:=1}/g' -i installkernel ||
+ die "enabling systemd's kernel-install failed"
+ fi
+
+ # set some default config using the flags we have anyway
+ touch "${T}/install.conf" || die
+ echo "# This file is managed by ${CATEGORY}/${PN}" >> "${T}/install.conf" || die
+ if use uki; then
+ echo "layout=uki" >> "${T}/install.conf" || die
+ elif use efistub; then
+ echo "layout=efistub" >> "${T}/install.conf" || die
+ elif use grub; then
+ echo "layout=grub" >> "${T}/install.conf" || die
+ elif use systemd-boot; then
+ echo "layout=bls" >> "${T}/install.conf" || die
+ else
+ echo "layout=compat" >> "${T}/install.conf" || die
+ fi
+
+ if use dracut; then
+ echo "initrd_generator=dracut" >> "${T}/install.conf" || die
+ if ! use ukify; then
+ if use uki; then
+ echo "uki_generator=dracut" >> "${T}/install.conf" || die
+ else
+ echo "uki_generator=none" >> "${T}/install.conf" || die
+ fi
+ fi
+ elif use ugrd; then
+ echo "initrd_generator=ugrd" >> "${T}/install.conf" || die
+ else
+ echo "initrd_generator=none" >> "${T}/install.conf" || die
+ fi
+
+ if use ukify; then
+ echo "uki_generator=ukify" >> "${T}/install.conf" || die
+ else
+ if ! use dracut; then
+ echo "uki_generator=none" >> "${T}/install.conf" || die
+ fi
+ fi
+
+ insinto /usr/lib/kernel
+ doins "${T}/install.conf"
+
+ insinto /etc/logrotate.d
+ newins installkernel.logrotate installkernel
+ keepdir /var/lib/misc
+
+ into /
+ dosbin installkernel
+ doman installkernel.8
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ # show only when upgrading to 14+
+ if ver_replacing -lt 14; then
+ elog "Version 14 and up of ${PN} effectively merges"
+ elog "${PN}-gentoo and ${PN}-systemd."
+ elog "Switching between the traditional installkernel and systemd's"
+ elog "kernel-install is controlled with the systemd USE flag or the"
+ elog "SYSTEMD_KERNEL_INSTALL environment variable."
+ elog
+ elog "See the installkernel wiki page[1] for more details."
+ elog
+ elog "[1]: https://wiki.gentoo.org/wiki/Installkernel"
+ elog
+ fi
+
+ # show only on first install of version 20+
+ if [[ -z "${REPLACING_VERSIONS}" ]] || ver_replacing -lt 20; then
+ if has_version "sys-boot/grub" && ! use grub; then
+ elog "sys-boot/grub is installed but the grub USE flag is not enabled."
+ elog "Users may want to enable this flag to automatically update the"
+ elog "bootloader configuration on each kernel install."
+ fi
+ if ( has_version "sys-apps/systemd[boot]" ||
+ has_version "sys-apps/systemd-utils[boot]" ) &&
+ ! use systemd-boot; then
+ elog "systemd-boot is installed but the systemd-boot USE flag"
+ elog "is not enabled. Users should enable this flag to install kernels"
+ elog "in a layout that systemd-boot understands and to automatically"
+ elog "update systemd-boot's configuration on each kernel install."
+ fi
+ fi
+
+ if use efistub; then
+ ewarn "Automated EFI Stub booting is highly experimental. UEFI implementations"
+ ewarn "often differ between vendors and as a result EFI stub booting is not"
+ ewarn "guaranteed to work for all UEFI systems. Ensure an alternative method"
+ ewarn "of booting the system is available before rebooting."
+ fi
+
+ # Initialize log file if there is none
+ dodir /var/log
+ local log=${ROOT}/var/log/installkernel.log
+ if [[ ! -s ${log} ]]; then
+ echo -e \
+"DATE\t"\
+"KI_VENDOR\t"\
+"VERSION\t"\
+"CONF_ROOT\t"\
+"LAYOUT\t"\
+"INITRD_GEN\t"\
+"UKI_GEN\t"\
+"BOOT_ROOT\t"\
+"KERNEL_REL_PATH\t"\
+"INITRD_REL_PATH\t"\
+"PLUGIN_OVERRIDE\t"\
+>> "${log}" || die
+ fi
+}