summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-docs/linux-docs-6.1.70.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
commit3daf38ec350b4e25244c69eea165b18afd090459 (patch)
tree5489bd5abdccd746fe68e98b9164e887bfbcfde4 /sys-kernel/linux-docs/linux-docs-6.1.70.ebuild
parent84bfe2244c544bae8dcaffbaf4cfb80f59f88f64 (diff)
gentoo auto-resync : 04:01:2024 - 20:01:09
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-6.1.70.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-6.1.70.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-6.1.70.ebuild b/sys-kernel/linux-docs/linux-docs-6.1.70.ebuild
new file mode 100644
index 000000000000..e59cedb990c3
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-6.1.70.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11} )
+inherit linux-info python-any-r1 toolchain-funcs
+
+MY_P=linux-${PV}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v6.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="graphviz"
+
+DEPEND=""
+RDEPEND="graphviz? ( >=media-gfx/graphviz-5.0.0 )"
+BDEPEND="${PYTHON_DEPS}
+ >=dev-python/sphinx-7.2.3
+ dev-python/sphinx-rtd-theme
+ media-libs/fontconfig"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
+
+src_compile() {
+ local ARCH="$(tc-arch-kernel)"
+ unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
+ emake htmldocs
+}
+
+src_install() {
+ einstalldocs
+}