summaryrefslogtreecommitdiff
path: root/sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-07 21:43:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-07 21:43:38 +0100
commitcda4539525c6eb3d5a55c383719645b9409e1aad (patch)
treec3d23caedf1273945290ebe06153b2109c792846 /sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild
parenta693a49d235bea057923bcbc2ee6a40cce4bb060 (diff)
gentoo auto-resync : 07:06:2023 - 21:43:38
Diffstat (limited to 'sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild
new file mode 100644
index 000000000000..c64869addb18
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-6.1.21_p20230405.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+
+K_EXP_GENPATCHES_NOUSE=1
+K_GENPATCHES_VER=25
+K_DEBLOB_AVAILABLE=0
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 linux-info
+detect_version
+detect_arch
+
+MY_P=$(ver_cut 4-)
+MY_P="1.${MY_P/p/}"
+
+DESCRIPTION="Raspberry Pi kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+SRC_URI="
+ https://github.com/raspberrypi/linux/archive/${MY_P}.tar.gz -> linux-${KV_FULL}.tar.gz
+ ${GENPATCHES_URI}
+"
+
+KEYWORDS="~arm ~arm64"
+
+PATCHES=("${FILESDIR}"/${PN}-5.15.32-gentoo-kconfig.patch)
+
+UNIPATCH_EXCLUDE="
+ 10*
+ 15*
+ 2000
+ 29*
+ 3000
+ 4567"
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the raspberrypi developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+universal_unpack() {
+ unpack linux-${KV_FULL}.tar.gz
+
+ # We want to rename the unpacked directory to a nice normalised string
+ # bug #762766
+ mv "${WORKDIR}"/linux-${MY_P} "${WORKDIR}"/linux-${KV_FULL} || die
+
+ # remove all backup files
+ find . -iname "*~" -exec rm {} \; 2>/dev/null
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}