summaryrefslogtreecommitdiff
path: root/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild')
-rw-r--r--sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild b/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
new file mode 100644
index 000000000000..24de50f1790b
--- /dev/null
+++ b/sys-libs/cygwin-crypt/cygwin-crypt-1.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Cygwin Encryption/Decryption utility and library"
+HOMEPAGE="https://sourceware.org/cygwin-apps/"
+# Upstream provides the git repo only, so we do:
+# git clone git://cygwin.com/git/cygwin-apps/crypt.git
+# cd crypt
+# git archive -o cygwin-crypt-${PV}.tar --prefix=cygwin-crypt-${PV}/ crypt-${PV}-release
+# bzip2 cygwin-crypt-${PV}.tar
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~x64-cygwin"
+
+mymake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/share/doc/${P}" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_install() {
+ mymake install DESTDIR="${D}"
+}