summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.37-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
commit5c636a121a9064a4373d06b60d49a6f5d67c0e2f (patch)
tree8e5c8c582e12cb579ac94bdaafcd00282252a50d /sys-libs/glibc/glibc-2.37-r3.ebuild
parentb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (diff)
gentoo auto-resync : 25:07:2023 - 05:42:52
Diffstat (limited to 'sys-libs/glibc/glibc-2.37-r3.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.37-r3.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.37-r3.ebuild b/sys-libs/glibc/glibc-2.37-r3.ebuild
index f46cdcac0bfa..c3c9ca521d37 100644
--- a/sys-libs/glibc/glibc-2.37-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.37-r3.ebuild
@@ -6,13 +6,10 @@ EAPI=8
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-# Please keep the python line in BDEPEND updated and do NOT use eclasses pr
-# ${PYTHON_DEPS} (since they are too strict and lead to problems with the
-# package order during upgrades).
-
+PYTHON_COMPAT=( python3_{9..11} )
TMPFILES_OPTIONAL=1
-inherit prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
+inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
multilib systemd multiprocessing tmpfiles
DESCRIPTION="GNU libc C library"
@@ -104,7 +101,7 @@ IDEPEND="
!compile-locales? ( sys-apps/locale-gen )
"
BDEPEND="
- || ( dev-lang/python:3.11 dev-lang/python:3.10 dev-lang/python:3.9 )
+ ${PYTHON_DEPS}
>=app-misc/pax-utils-${MIN_PAX_UTILS_VER}
sys-devel/bison
compile-locales? ( sys-apps/locale-gen )
@@ -867,6 +864,13 @@ pkg_pretend() {
upgrade_warning
}
+# pkg_setup
+
+pkg_setup() {
+ # see bug 682570
+ [[ -z ${BOOTSTRAP_RAP} ]] && python-any-r1_pkg_setup
+}
+
# src_unpack
src_unpack() {