summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 19:03:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 19:03:28 +0000
commitf03f06fb7152586e3084ebabe54d93f28da8bf6d (patch)
treef476e8d7696af448ddbe831c85e80189b64bc411 /sys-libs/glibc/glibc-9999.ebuild
parentc6985b401141ea8b5ec4b95c4ad3a5a21ef32571 (diff)
gentoo auto-resync : 09:01:2024 - 19:03:28
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a1efdfa51e2c..4740163cf11f 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1082,16 +1082,6 @@ glibc_do_configure() {
echo "$@"
"$@" || die "failed to configure glibc"
- # ia64 static cross-compilers are a pita in so much that they
- # can't produce static ELFs (as the libgcc.a is broken). so
- # disable building of the programs for those targets if it
- # doesn't work.
- # XXX: We could turn this into a compiler test, but ia64 is
- # the only one that matters, so this should be fine for now.
- if is_crosscompile && [[ ${CTARGET} == ia64* ]] ; then
- sed -i '1i+link-static = touch $@' config.make
- fi
-
# If we're trying to migrate between ABI sets, we need
# to lie and use a local copy of gcc. Like if the system
# is built with MULTILIB_ABIS="amd64 x86" but we want to
@@ -1117,7 +1107,7 @@ glibc_headers_configure() {
# the best here ...
local v vars=(
ac_cv_header_cpuid_h=yes
- libc_cv_{386,390,alpha,arm,hppa,ia64,mips,{powerpc,sparc}{,32,64},sh,x86_64}_tls=yes
+ libc_cv_{386,390,alpha,arm,hppa,mips,{powerpc,sparc}{,32,64},sh,x86_64}_tls=yes
libc_cv_asm_cfi_directives=yes
libc_cv_broken_visibility_attribute=no
libc_cv_c_cleanup=yes