summaryrefslogtreecommitdiff
path: root/sys-libs/ldb/ldb-2.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-27 16:34:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-27 16:34:32 +0100
commit1a7ba844ad2c84ac4ba0d37f510285e778c7ffc4 (patch)
tree6b0c029b423e831d2d4be3aea13954182623d7f4 /sys-libs/ldb/ldb-2.7.2.ebuild
parenta12f416baa722b8bda57c0d527fb28b3d06b2aeb (diff)
gentoo auto-resync : 27:07:2023 - 16:34:32
Diffstat (limited to 'sys-libs/ldb/ldb-2.7.2.ebuild')
-rw-r--r--sys-libs/ldb/ldb-2.7.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-libs/ldb/ldb-2.7.2.ebuild b/sys-libs/ldb/ldb-2.7.2.ebuild
index 76e28c619894..959a12c27046 100644
--- a/sys-libs/ldb/ldb-2.7.2.ebuild
+++ b/sys-libs/ldb/ldb-2.7.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
inherit python-single-r1 waf-utils multilib-minimal
@@ -13,11 +13,11 @@ SRC_URI="https://samba.org/ftp/pub/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="doc ldap +lmdb python test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- test? ( lmdb python )"
+ test? ( lmdb )"
RESTRICT="!test? ( test )"
@@ -99,6 +99,12 @@ src_prepare() {
check_samba_dep_versions
+ if use test && ! use python ; then
+ # We want to be able to run tests w/o Python as it makes
+ # automated testing much easier (as USE=python isn't default-enabled).
+ truncate -s0 tests/python/{repack,index,api,crash}.py || die
+ fi
+
multilib_copy_sources
}