summaryrefslogtreecommitdiff
path: root/sys-libs/libblockdev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sys-libs/libblockdev
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sys-libs/libblockdev')
-rw-r--r--sys-libs/libblockdev/Manifest2
-rw-r--r--sys-libs/libblockdev/libblockdev-2.24.ebuild123
2 files changed, 125 insertions, 0 deletions
diff --git a/sys-libs/libblockdev/Manifest b/sys-libs/libblockdev/Manifest
index d0d4b1e5464a..7cfec11f1e70 100644
--- a/sys-libs/libblockdev/Manifest
+++ b/sys-libs/libblockdev/Manifest
@@ -1,5 +1,7 @@
AUX libblockdev-2.23-avoid_bashisms.patch 1760 BLAKE2B 37cdc9ca0a002525646f6a9de162b6a30f3ae9fd331232e3c5bbe287fac687a1ccc496036f94cfa568100c095b7e947e6f6b5ed00a8d926857c102de7b8ce53b SHA512 abba5f533c35e5be47e83e86d3ccc630e122adb465741bfc888d0f6bee2fdcc96ec820626dd02e08fc46a01d30a04652f1d587a9ddef7bb9c58bec7b9053f767
DIST libblockdev-2.23.tar.gz 856829 BLAKE2B 131bf429e530fc9dd44fade4f5bc937ec220365b1ee2ae46818a6fa3ec7591775fdc3ed531350cc2546f4151e41551dfd3e331b0a6d5777769a7b54c5c15ed42 SHA512 ecc4d5a3cb977fbbe176bf6872b6754833d2869e927c32f8466685916ee4550cf806e0b0c8f5e8e76de3839ae591a4eec502ff974c2f0678af6cfd46dd3016f3
+DIST libblockdev-2.24.tar.gz 905838 BLAKE2B dcc31021d72c2a4f92d8f70387537ec409302e85a9bdb338a09449b02318113d40cabf7fc2f6b4aca819400baccba69a9f67a616b30c744cf843eeac785875e4 SHA512 92b7d734ea2cefbb67e626bef369d6785ba2a4bbbf09a4f59345febe977bc32319fb44f38b3c3177b8652abbc1f87b6cc76d41fdd2d70783c1c168049bdcb1d6
EBUILD libblockdev-2.23-r1.ebuild 2634 BLAKE2B d1260e7a462fa469ef96026b57073f094ba270a50166f59fc4727686946f15cd50cee2bfdace38c763bad4035c25e4496da6a42883227d237a5bc7a1c5d6e655 SHA512 2bd2d27d1e052e906ac3f0ca27a45590d45be55d30e4f7af485fc9580d7dec2235bba49730dddccc7bf6ec46d5df489b15cd9f3d7606fb1deab9a959d033a799
+EBUILD libblockdev-2.24.ebuild 2606 BLAKE2B f4780c6c02ca95eca1a1b8968c0a28741f06e785e7c7f920d8d9b7dd27f29f1f932e07037db6873a872bba840b522d39e85c034a87929515744562892d236ccc SHA512 eb41e982a8e9607fbd0272aced19f3fecce0a35486cc841af45f4b000eadc1551d0a131d7ac1d480747b38ad0be67b23c216be9d959ad19bdc37721580ce2dc2
EBUILD libblockdev-9999.ebuild 2606 BLAKE2B f4780c6c02ca95eca1a1b8968c0a28741f06e785e7c7f920d8d9b7dd27f29f1f932e07037db6873a872bba840b522d39e85c034a87929515744562892d236ccc SHA512 eb41e982a8e9607fbd0272aced19f3fecce0a35486cc841af45f4b000eadc1551d0a131d7ac1d480747b38ad0be67b23c216be9d959ad19bdc37721580ce2dc2
MISC metadata.xml 1079 BLAKE2B 927991dfdfefd599210651f76fa8bffbd5a54700791b57847a9ecf85cd1aa04a449eea84c4e1ee3e9eb50e541eab3d97a6218c814a018439aa6f520970a8acca SHA512 492cabe5b464c0bae48e8def1e771a27f28bcd03a47276be26a4351367bcd53e198358f8c0cbf25cd0c6c8e841ee67435b22fbe669bde1a6aa74668e70fa8fc9
diff --git a/sys-libs/libblockdev/libblockdev-2.24.ebuild b/sys-libs/libblockdev/libblockdev-2.24.ebuild
new file mode 100644
index 000000000000..1ea252a8b26c
--- /dev/null
+++ b/sys-libs/libblockdev/libblockdev-2.24.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="A library for manipulating block devices"
+HOMEPAGE="https://github.com/storaged-project/libblockdev"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
+ BDEPEND="
+ sys-devel/autoconf-archive
+ "
+else
+ MY_PV="${PV}-1"
+ #MY_P="${PN}-${MY_PV}"
+ #SRC_URI="https://github.com/storaged-project/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ SRC_URI="https://github.com/storaged-project/${PN}/releases/download/${MY_PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ #S="${WORKDIR}/${MY_P}"
+fi
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="bcache +cryptsetup device-mapper dmraid escrow gtk-doc introspection lvm kbd test +tools vdo"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.2
+ dev-libs/libbytesize
+ >=sys-apps/kmod-19
+ >=sys-apps/util-linux-2.27
+ >=sys-block/parted-3.1
+ cryptsetup? (
+ escrow? (
+ >=dev-libs/nss-3.18.0
+ dev-libs/volume_key
+ )
+ >=sys-fs/cryptsetup-1.6.7:=
+ )
+ device-mapper? ( sys-fs/lvm2 )
+ dmraid? (
+ sys-fs/dmraid
+ sys-fs/lvm2
+ )
+ lvm? (
+ sys-fs/lvm2
+ virtual/udev
+ )
+ vdo? ( dev-libs/libyaml )
+ ${PYTHON_DEPS}
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND+="
+ dev-util/gtk-doc-am
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( >=dev-libs/gobject-introspection-1.3.0 )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ escrow? ( cryptsetup )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_environment_reset #623992
+ default
+ [[ "${PV}" == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-btrfs
+ --with-fs
+ --with-part
+ --without-mpath
+ --without-nvdimm
+ $(use_enable introspection)
+ $(use_enable test tests)
+ $(use_with bcache)
+ $(use_with cryptsetup crypto)
+ $(use_with device-mapper dm)
+ $(use_with dmraid)
+ $(use_with escrow)
+ $(use_with gtk-doc)
+ $(use_with kbd)
+ $(use_with lvm lvm)
+ $(use_with lvm lvm-dbus)
+ $(use_with tools)
+ $(use_with vdo)
+ )
+ if python_is_python3 ; then
+ myeconfargs+=(
+ --without-python2
+ --with-python3
+ )
+ else
+ myeconfargs+=(
+ --with-python2
+ --without-python3
+ )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+ # This is installed even with USE=-lvm, but libbd_lvm are omitted so it
+ # doesn't work at all.
+ if ! use lvm; then
+ rm -f "${ED}"/usr/bin/lvm-cache-stats || die
+ fi
+ python_optimize #718576
+}