summaryrefslogtreecommitdiff
path: root/sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 17:34:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 17:34:25 +0000
commit0bb42730e8fc9c8e571f12e3189c6c6f8d532c24 (patch)
treecba6032fbed30be2b0764494607c3ec9dda0c18a /sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild
parentcc901a8ce7c6bfe97e3b4f048619693d360ae348 (diff)
gentoo auto-resync : 10:02:2024 - 17:34:25
Diffstat (limited to 'sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild
index 2c496689828b..d45de5993114 100644
--- a/sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-19.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="Low level support for a standard C++ library"
HOMEPAGE="https://libcxxabi.llvm.org/"
@@ -45,16 +45,9 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-pkg_setup() {
- # darwin prefix builds do not have llvm installed yet, so rely on bootstrap-prefix
- # to set the appropriate path vars to LLVM instead of using llvm_pkg_setup.
- if [[ ${CHOST} != *-darwin* ]] || has_version sys-devel/llvm; then
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- fi
- python-any-r1_pkg_setup
-}
-
multilib_src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++