summaryrefslogtreecommitdiff
path: root/sys-libs/libhx/libhx-4.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
commitcc901a8ce7c6bfe97e3b4f048619693d360ae348 (patch)
treec250ff07a4d508fa08b487b616e0ae8aff2f0d8e /sys-libs/libhx/libhx-4.21.ebuild
parentc9badf79e4669147edb94182af5776072f2ffaea (diff)
gentoo auto-resync : 10:02:2024 - 11:34:00
Diffstat (limited to 'sys-libs/libhx/libhx-4.21.ebuild')
-rw-r--r--sys-libs/libhx/libhx-4.21.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-libs/libhx/libhx-4.21.ebuild b/sys-libs/libhx/libhx-4.21.ebuild
new file mode 100644
index 000000000000..9126c9cafb8e
--- /dev/null
+++ b/sys-libs/libhx/libhx-4.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Platform independent library providing basic system functions"
+HOMEPAGE="https://inai.de/projects/libhx/"
+SRC_URI="https://inai.de/files/${PN}/libHX-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/32" # soname version
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+BDEPEND="app-arch/xz-utils"
+
+S="${WORKDIR}/libHX-${PV}"
+
+src_install() {
+ default
+
+ if use doc; then
+ dodoc doc/*.txt doc/*.rst
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}