summaryrefslogtreecommitdiff
path: root/sys-libs/libnbd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /sys-libs/libnbd
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'sys-libs/libnbd')
-rw-r--r--sys-libs/libnbd/Manifest1
-rw-r--r--sys-libs/libnbd/libnbd-1.18.1-r1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-libs/libnbd/Manifest b/sys-libs/libnbd/Manifest
index 29c987dbb2ee..a3d60a9e510b 100644
--- a/sys-libs/libnbd/Manifest
+++ b/sys-libs/libnbd/Manifest
@@ -3,5 +3,6 @@ DIST libnbd-1.16.1.tar.gz 1379437 BLAKE2B 13020c21663e988d46fb5a048b31c58b0256c7
DIST libnbd-1.18.1.tar.gz 1482736 BLAKE2B d3f0b2993fa1392df93b0bbc5d63805489ad1a82cf5bcc5eb5c3b5b7e7e6c40095471ab8fc964cc0e5c7a99affa7150f7be38cc16c42f27fc4cdc16bd0ca0359 SHA512 f4262666be55d580550e053355f14f80d352bf869ae7241e9fa032a9b5cd9e027eb89a536871c1206422413fc7ed745da7d612b3e1413f76ec17168705fbf12c
EBUILD libnbd-1.14.1.ebuild 1312 BLAKE2B 9972d0595b29b56b6d9f4ed1bcc32b95576522ce50c185effec698101e8d903220c6153fcaaac7cd58388f79c17f4c160e02667639838f8b3cfc92a874327c88 SHA512 ee216b3776d71fbd30569aa243b09a4432346082f0d2c077b3ff1959575d586d3d5528fea20a7dae03544e5be24d11fb5771c1730d4262d5ca59187aa1a8167d
EBUILD libnbd-1.16.1-r1.ebuild 1676 BLAKE2B e53214b35a0e5cc1a0b6fa78d86b523c70d9cde10e0ae54692842a3708884e9fed8a8fd83fbd3960e7d9fa8119d5fd3dda59395be511bbac6201da6121034b68 SHA512 26401e140d446408021ab5d1fddb84fdebbbf783a4646ac2e2cd7b7b228065377c893dfa9be63597e09201a4d723ea258626f15fa1583d8b6ec3a484b7dcc971
+EBUILD libnbd-1.18.1-r1.ebuild 1745 BLAKE2B 382a29274d2e22905b404faf3b5c0ecd911418b5ea27b9c2b7b3b9cb6b69f3eaf2317f7b91efddbbc525b6b24fce85c7640725cd70f9021cb62a55588803403a SHA512 da6835ca01b09046d9749b7c7adb53c30852180f2ff64d930d70864a0328a47a08271dac332a751362aeb4a44ef07488c38fd8abfb67d06c598918312d1744c5
EBUILD libnbd-1.18.1.ebuild 1744 BLAKE2B 5ebb35d2a7d18d53dbd87d587a047f5b0a0a81dcd6008677d1baa92d1d298d6cff96b57159f40c6654c7c1b7fa6f329bff9514c081b1d7df25508109d8fb0acc SHA512 91d1990dbc79272c2657fac22d73025685ec1eb8472f271061f788bc5cdf4c2daf35158707765139f6d87b820c5a40e49271768430e41014f7e65290c0608d37
MISC metadata.xml 659 BLAKE2B c967019226aa8369e3442729873d1a250440eebf22b85cb998b6896a2ca0d7ba384d0c3c411de26f18304c3fd8fe6d422b904a0f147f6dc9160b8e505ecb3b1c SHA512 1ba695faff69662dfa4053c1a955e9e73dc04d9cb6c54ffb19fefe5b17d36fab2aa179756826763a2927ef3d04a00a8e640725529d4fbdf83a8f400156841045
diff --git a/sys-libs/libnbd/libnbd-1.18.1-r1.ebuild b/sys-libs/libnbd/libnbd-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..accecba8e4d2
--- /dev/null
+++ b/sys-libs/libnbd/libnbd-1.18.1-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="NBD client library in userspace"
+HOMEPAGE="https://gitlab.com/nbdkit/libnbd"
+SRC_URI="https://download.libguestfs.org/libnbd/$(ver_cut 1-2)-stable/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="fuse gnutls go ocaml python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# libxml2 - URI support
+RDEPEND="
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse:3 )
+ gnutls? ( net-libs/gnutls:= )
+ python? ( ${PYTHON_DEPS} )
+ go? ( dev-lang/go )
+ ocaml? ( >=dev-lang/ocaml-4.03:=[ocamlopt] )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ sys-block/nbd[gnutls?]
+ sys-block/nbdkit[gnutls?]
+ )
+"
+BDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+
+ # Some tests require impossible to provide features, such as fuse.
+ # These are marked by requires_... in the functions.sh shell
+ # library. Rather than listing these tests, let's list out the
+ # impossible to support features and make them skip.
+ cat <<-EOF >> tests/functions.sh.in || die
+ requires_fuse ()
+ {
+ requires false
+ }
+ EOF
+
+ # Broken under sandbox.
+ cat <<-EOF > lib/test-fork-safe-execvpe.sh || die
+ #!/bin/sh
+ :
+ EOF
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable go golang)
+ $(use_enable ocaml)
+ $(use_enable python)
+ $(use_with gnutls)
+ --disable-rust # TODO(arsen): security bump takes priority
+ --with-libxml2
+ )
+
+ export bashcompdir="$(get_bashcompdir)"
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ use python && python_optimize
+}