summaryrefslogtreecommitdiff
path: root/sys-libs/libosinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /sys-libs/libosinfo
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'sys-libs/libosinfo')
-rw-r--r--sys-libs/libosinfo/Manifest2
-rw-r--r--sys-libs/libosinfo/libosinfo-1.3.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-libs/libosinfo/Manifest b/sys-libs/libosinfo/Manifest
index a25851a09035..9e4c32d2a2a0 100644
--- a/sys-libs/libosinfo/Manifest
+++ b/sys-libs/libosinfo/Manifest
@@ -1,3 +1,5 @@
DIST libosinfo-1.2.0.tar.gz 916787 BLAKE2B 652910ca1e70071d88adb771e458f0c19159a772eec1178c94ea5f65c5045bb00e4b1354b1ce4229d28821b6b1557424e419c1505b721883731a36b0761a1b5d SHA512 d98a107a08c5e2cddd746631b3ceac4278184ea5561ad2372d772b8ae253dc1363f217778d105387e5b5c5e86be9607668aa94929ad9b4ee48ab7abf50fb6a01
+DIST libosinfo-1.3.0.tar.gz 977090 BLAKE2B fdfe29dbf01e00608374baf2fb6b5257dff5eb8870375769c572b4dacf2bd7f6e1907083e6c36bfb1a76e9e994bb19b093c6fc63ce8e7170ab8073f6d53c573b SHA512 652f2927e901afe9772d4f28be5bb59802cf149c6c8eea4256a999f5012bfaaac81b51c56a94b32c82ef3462ff1f26baf84bf9329e5b1136e2b49ed4a0658982
EBUILD libosinfo-1.2.0.ebuild 1733 BLAKE2B 6d8f39bfe7139b5a9103922b61768f458a8ac5db914bb4b7cd4a13b897d5fb1b062adfd81a6aca778a97475ec95835a386904f2bf70a413a992bc3fa3f7c5b67 SHA512 331e01a546b7b81c1d88d2bec8984e15747924d40b6caac719680dae5af709d9816c06bc7eea9c19a9202648c3245191b107390a5097af7323e3c3910fb33dd2
+EBUILD libosinfo-1.3.0.ebuild 1735 BLAKE2B 1f801329230accb0474f9dd56afe2892c0e3d0437bb0d2998b8850a411c7e1b0970bbb0f62814fabb770206b6fe87e309e333759634b90cdf15e577e20f2af24 SHA512 b2a41f2016861fb9bb5c1c323603e50c44ee784581d211dbe1307ea2345a60613924305179ac0bf894ba12051c06da14b811842b123d3e57ee34dd127c55ae55
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/sys-libs/libosinfo/libosinfo-1.3.0.ebuild b/sys-libs/libosinfo/libosinfo-1.3.0.ebuild
new file mode 100644
index 000000000000..277498d87879
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-1.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 udev vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="+introspection +vala test"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Unsure about osinfo-db-tools rdep, but at least fedora does it too
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=dev-libs/libxml2-2.6.0
+ >=dev-libs/libxslt-1.0.0
+ sys-apps/hwids[pci,usb]
+ sys-apps/osinfo-db-tools
+ sys-apps/osinfo-db
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+# perl dep is for pod2man, and configure.ac checks for it too now
+# Tests can use net-misc/curl, but they are automatically skipped if curl is not found, and
+# if it is found, then those tests are skipped at runtime if LIBOSINFO_NETWORK_TESTS is unset.
+# Due to potential network-sandbox we aren't enabling them (and one of them fails at 1.2.0).
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/gobject-introspection-common
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ test? (
+ >=sys-apps/osinfo-db-20180612
+ )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-usb-ids-path=/usr/share/misc/usb.ids \
+ --with-pci-ids-path=/usr/share/misc/pci.ids \
+ --disable-static \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --disable-coverage
+}