summaryrefslogtreecommitdiff
path: root/sys-libs/libsmbios/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-libs/libsmbios/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-libs/libsmbios/files')
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch10
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch16
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch19
-rw-r--r--sys-libs/libsmbios/files/libsmbios-fix-pie.patch29
4 files changed, 74 insertions, 0 deletions
diff --git a/sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch b/sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch
new file mode 100644
index 000000000000..ed8599ecff9c
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch
@@ -0,0 +1,10 @@
+--- libsmbios-2.2.28/src/libsmbios_c/smi/smi_linux.c
++++ libsmbios-2.2.28/src/libsmbios_c/smi/smi_linux.c
+@@ -48,6 +48,7 @@
+ #define bufsize 256
+
+ // not in header file. for private use by unit tests.
++LIBSMBIOS_C_DLL_SPEC void set_basedir(const char *); // needed to link tests
+ void set_basedir(const char *newdir)
+ {
+ sysfs_basedir = newdir;
diff --git a/sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch b/sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch
new file mode 100644
index 000000000000..ebe6798bd731
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch
@@ -0,0 +1,16 @@
+--- libsmbios-2.3.0/Makefile.am
++++ libsmbios-2.3.0/Makefile.am
+@@ -89,10 +89,12 @@
+
+
+ ########## DOCS ################
+-all: doxygen
+ if HAVE_DOXYGEN
++all: doxygen
+ DOXYGEN_DEPS=out/libsmbios_c/html/index.html out/libsmbios_c++/html/index.html
+ doxygen: $(DOXYGEN_DEPS)
++else
++all:
+ endif
+
+ DOT=@DOT@
diff --git a/sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch b/sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch
new file mode 100644
index 000000000000..4adca14f21d8
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch
@@ -0,0 +1,19 @@
+--- libsmbios-2.3.3/Makefile.am
++++ libsmbios-2.3.3/Makefile.am
+@@ -89,13 +89,15 @@
+
+
+ ########## DOCS ################
+-all: doxygen
+ if HAVE_DOXYGEN
++all: doxygen
+ DOXYGEN_DEPS=out/libsmbios_c/html/index.html
+ if BUILD_LIBSMBIOS_CXX
+ DOXYGEN_DEPS+=out/libsmbios_c++/html/index.html
+ endif
+ doxygen: $(DOXYGEN_DEPS)
++else
++all:
+ endif
+
+ DOT=@DOT@
diff --git a/sys-libs/libsmbios/files/libsmbios-fix-pie.patch b/sys-libs/libsmbios/files/libsmbios-fix-pie.patch
new file mode 100644
index 000000000000..3ab404e8ea2e
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-fix-pie.patch
@@ -0,0 +1,29 @@
+--- libsmbios-2.2.19/src/bin/dellMediaDirectCtl.cpp
++++ libsmbios-2.2.19/src/bin/dellMediaDirectCtl.cpp
+@@ -183,16 +183,21 @@
+ {
+ iopl(3);
+
++ u32 tmpebx;
+ __asm__ __volatile__ (
+- // magic port
+- "outb %%al, %%dx \n\t"
+-
++ "movl %%ebx,%[tmpebx]\n\t"
++ "movl %[ebx],%%ebx\n\t"
++ // magic port
++ "outb %%al, %%dx \n\t"
++ "movl %%ebx,%[ebx]\n\t"
++ "movl %[tmpebx],%%ebx\n\t"
+ : /* output args */
+ "=a" (r->eax),
+- "=b" (r->ebx),
++ [ebx] "=rm" (r->ebx),
+ "=c" (r->ecx),
+ "=S" (r->esi),
+- "=D" (r->edi)
++ "=D" (r->edi),
++ [tmpebx] "+m" (tmpebx)
+ : /* input args */
+ "0" (r->eax),
+ "1" (r->ebx),