summaryrefslogtreecommitdiff
path: root/sys-libs/native-uuid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /sys-libs/native-uuid
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'sys-libs/native-uuid')
-rw-r--r--sys-libs/native-uuid/Manifest2
-rw-r--r--sys-libs/native-uuid/metadata.xml15
-rw-r--r--sys-libs/native-uuid/native-uuid-1.0.ebuild36
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-libs/native-uuid/Manifest b/sys-libs/native-uuid/Manifest
new file mode 100644
index 000000000000..726b96a12342
--- /dev/null
+++ b/sys-libs/native-uuid/Manifest
@@ -0,0 +1,2 @@
+EBUILD native-uuid-1.0.ebuild 701 BLAKE2B 40d9e50877a40b9f784f3526a60ad845c259109b8da245bf5ae8c04eeb483e3957b1573fbfc41681706b31eaf650699c6cedf92d05f6f839fda33766c4266387 SHA512 0064541825531d80f12e4e3ef9409d3b2e4049d56bf2830d50ab1085a1451ab8dd4935681098685e5944b56f54a696242649d82f19128a5793da86307b3c6be3
+MISC metadata.xml 464 BLAKE2B ed7b8ddc489f3b55ff96f06a49d270881423481b2e99ab8e1470e30b8535f7258cf07cdb7128a99cc65b095d8628f26bfda8c51c9dfa1793da91c160ff26faa8 SHA512 dcd353281c0d18ad7414071fe46861733cc928be817c283b2f4ab9aeb7ef0d35551db62f29380e613f78cdd4dd1718fe404335f0210e1dabe364c2eb0abfbcec
diff --git a/sys-libs/native-uuid/metadata.xml b/sys-libs/native-uuid/metadata.xml
new file mode 100644
index 000000000000..06454c38b1ef
--- /dev/null
+++ b/sys-libs/native-uuid/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>prefix@gentoo.org</email>
+ <name>Gentoo Prefix</name>
+ </maintainer>
+ <longdescription lang="en">
+ pkgconfig file for host-provided uuid for Prefix systems
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-libs/native-uuid/native-uuid-1.0.ebuild b/sys-libs/native-uuid/native-uuid-1.0.ebuild
new file mode 100644
index 000000000000..2f7e48e9fc4a
--- /dev/null
+++ b/sys-libs/native-uuid/native-uuid-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION=".pc file for uuid"
+HOMEPAGE="https://prefix.gentoo.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="!!sys-libs/libuuid
+ !!sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+}
+
+src_install() {
+ mkdir -p "${ED}"/usr/lib/pkgconfig || die
+ cat > "${ED}"/usr/lib/pkgconfig/uuid.pc <<- EOPC
+ prefix=${EPREFIX}/usr
+ exec_prefix=\${prefix}
+ libdir=${EPREFIX}/usr/lib
+ includedir=\${prefix}/include
+
+ Name: uuid
+ Description: Universally unique id library
+ Version: ${PV}
+ Requires:
+ Cflags:
+ Libs:
+ EOPC
+}