summaryrefslogtreecommitdiff
path: root/sys-libs/ncurses/ncurses-6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-22 14:28:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-22 14:28:15 +0000
commitaae71b4d8e684ca22d28ef0f1da0989e7bf6468d (patch)
tree0e9cf35d85726e6aa9fbd58b12035f92ffec0130 /sys-libs/ncurses/ncurses-6.4.ebuild
parent20ed81714fa97f5845db16a3c142b3b44d820bc4 (diff)
gentoo auto-resync : 22:02:2023 - 14:28:15
Diffstat (limited to 'sys-libs/ncurses/ncurses-6.4.ebuild')
-rw-r--r--sys-libs/ncurses/ncurses-6.4.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/sys-libs/ncurses/ncurses-6.4.ebuild b/sys-libs/ncurses/ncurses-6.4.ebuild
index 2bbacd762737..58a97be7ee7d 100644
--- a/sys-libs/ncurses/ncurses-6.4.ebuild
+++ b/sys-libs/ncurses/ncurses-6.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
-inherit flag-o-matic toolchain-funcs multilib-minimal preserve-libs usr-ldscript verify-sig
+inherit flag-o-matic toolchain-funcs multilib multilib-minimal preserve-libs usr-ldscript verify-sig
MY_PV="${PV:0:3}"
MY_P="${PN}-${MY_PV}"
@@ -142,6 +142,11 @@ src_configure() {
# bug #214642
BUILD_CPPFLAGS+=" -D_GNU_SOURCE"
+ # bug #852665
+ if [[ ${CHOST} == *-cygwin* ]]; then
+ BUILD_CPPFLAGS+=" -DBUILDING_NCURSES"
+ fi
+
# Build the various variants of ncurses -- narrow, wide, and threaded. #510440
# Order matters here -- we want unicode/thread versions to come last so that the
# binaries in /usr/bin support both wide and narrow.
@@ -288,17 +293,7 @@ do_configure() {
src_compile() {
# See comments in src_configure.
if ! has_version -b "~sys-libs/${P}:0" ; then
- # We could possibly merge these two branches but opting to be
- # conservative when merging some of the Prefix changes.
-
- if [[ ${CHOST} == *-cygwin* ]] && ! multilib_is_native_abi ; then
- # We make 'tic$(x)' here, for Cygwin having x=".exe".
- BUILD_DIR="${WORKDIR}" \
- do_compile cross -C progs all PROGS='tic$(x)'
- else
- BUILD_DIR="${WORKDIR}" \
- do_compile cross -C progs tic
- fi
+ BUILD_DIR="${WORKDIR}" do_compile cross -C progs tic$(get_exeext)
fi
multilib-minimal_src_compile