summaryrefslogtreecommitdiff
path: root/sys-libs/pam_wrapper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /sys-libs/pam_wrapper
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'sys-libs/pam_wrapper')
-rw-r--r--sys-libs/pam_wrapper/Manifest3
-rw-r--r--sys-libs/pam_wrapper/files/pam_wrapper-1.1.4-tests-import.patch22
-rw-r--r--sys-libs/pam_wrapper/pam_wrapper-1.1.4-r2.ebuild (renamed from sys-libs/pam_wrapper/pam_wrapper-1.1.4-r1.ebuild)24
3 files changed, 45 insertions, 4 deletions
diff --git a/sys-libs/pam_wrapper/Manifest b/sys-libs/pam_wrapper/Manifest
index 727edeb44f5d..2bddfddaa37f 100644
--- a/sys-libs/pam_wrapper/Manifest
+++ b/sys-libs/pam_wrapper/Manifest
@@ -1,3 +1,4 @@
+AUX pam_wrapper-1.1.4-tests-import.patch 767 BLAKE2B 65ce88028190bbbd3aacdf0a3af7591ebe90e4c24fb3502ef631ee8b126377cc6fe2a8a124658d5624e569235c9d48751e1f8142dbb87f5179d6017647991f3c SHA512 420704520ef5e4d6e1a5f4fca64619ab29765e9a5ddd347d1fc5427664e212695b6c19d7c15fe787f7375570378a261fab99c2b345ff7e96f3a7aaaf35e51939
DIST pam_wrapper-1.1.4.tar.gz 170882 BLAKE2B fa0a789f6fd6f809c7ef80e354e886b5f1f0b4212060dc0e388a44701e4a1f49635b8f47344156ad65cd273660e3b0a806480c37875a830e2f5d8e56c4ec0818 SHA512 3b68dc6d7815707d74d1340facd9c2de4dff3934402ac2c2632371b39c41a75744434744ed7308e157be03a03a941405638cadb6f34995de56fb1f5f45d37de2
-EBUILD pam_wrapper-1.1.4-r1.ebuild 1603 BLAKE2B f3267ab94ba926866c08f2f893a559f07f5841e4793949d1639903b818ed153b78df4cd0582b39a50fa59d536b3e252612b4eeaa1a84103b5c5ecbf63715ac83 SHA512 3c63be43be8acaaaa7136b137b438aeed12ac0859027a0fbc6d88f4c262e87fc0544f93e72c46c11d9544c7b01f4bcae6ad28b6efc6884e0d9478ab7651ca729
+EBUILD pam_wrapper-1.1.4-r2.ebuild 2004 BLAKE2B d6d48b2efdc291ace900f60424e35c05d45d9035d219461f6cf17fdffd0945e67d2267f96d0238cd463f2f373d02f137e50b4671a7480b23b54d098bf0f3b9a2 SHA512 836996c3788c513701b366d4f615fc2941ba52c8eb03df1427d9093e010e8c534cfa96c49c0bf92eb4570916f4a0cedb1d1594ddb3161a0e542bc9df3b269680
MISC metadata.xml 250 BLAKE2B e398673dd1a3522ccddb89a82a53fc2578d8e0777ec46f889d01d618609a22958d91699beef513c7912799e0e8ff985200f7c67bba941235da25c24cd4b48f09 SHA512 16834c3cbecd0dd5a9c8c311d2b8ebc63d8cd72c5891498f4f0048988993c104aadd4e24e632bf54071c11f810716432e89e4afab029555875f9f52794daa6e9
diff --git a/sys-libs/pam_wrapper/files/pam_wrapper-1.1.4-tests-import.patch b/sys-libs/pam_wrapper/files/pam_wrapper-1.1.4-tests-import.patch
new file mode 100644
index 000000000000..aba9c370a22c
--- /dev/null
+++ b/sys-libs/pam_wrapper/files/pam_wrapper-1.1.4-tests-import.patch
@@ -0,0 +1,22 @@
+--- a/tests/pypamtest_test.py
++++ b/tests/pypamtest_test.py
+@@ -15,19 +15,6 @@ class PyPamTestCase(unittest.TestCase):
+ self.assertSequenceEqual(test_result.errors, info_list)
+
+ class PyPamTestImport(unittest.TestCase):
+- def setUp(self):
+- " Make sure we load the in-tree module "
+- if sys.hexversion >= 0x3000000:
+- self.modpath = os.path.join(os.getcwd(), "../src/python/python3")
+- else:
+- self.modpath = os.path.join(os.getcwd(), "../src/python/python2")
+- self.system_path = sys.path[:]
+- sys.path = [ self.modpath ]
+-
+- def tearDown(self):
+- " Restore the system path "
+- sys.path = self.system_path
+-
+ def testImport(self):
+ " Import the module "
+ try:
diff --git a/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r1.ebuild b/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r2.ebuild
index 264a74d7a5c3..20e06b42b366 100644
--- a/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r1.ebuild
+++ b/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake-multilib python-r1
DESCRIPTION="A tool to test PAM applications and PAM modules"
@@ -31,6 +30,10 @@ DEPEND="
test? ( dev-util/cmocka[${MULTILIB_USEDEP}] )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.4-tests-import.patch
+)
+
multilib_src_configure() {
configure_for_python() {
local mycmakeargs=( -DUNIT_TESTING=OFF )
@@ -60,6 +63,21 @@ multilib_src_compile() {
cmake_src_compile
}
+multilib_src_test() {
+ cmake_src_test
+
+ # Fails b/c of sandbox?
+ #python_test() {
+ # local -x PYTHONPATH="${BUILD_DIR}/src/python/python3:${PYTHONPATH}"
+ # elog "${PYTHONPATH}"
+ # ${EPYTHON} "${S}"/tests/pypamtest_test.py || die "Tests failed with ${EPYTHON}"
+ #}
+
+ #if multilib_is_native_abi ; then
+ # python_foreach_impl python_test
+ #fi
+}
+
multilib_src_install() {
if multilib_is_native_abi ; then
python_foreach_impl cmake_src_install