summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
commitd69399c7befdd98cda62d6a1788ae2aa7f104c5e (patch)
treeeac7184f4cfe7d67580c1d0a0d9942a91e6cb4ee /sys-libs
parente4d9d6796d5018e338f0b27a3bc97716195bf0b8 (diff)
gentoo auto-resync : 07:01:2025 - 06:41:06
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/Manifest.gzbin13726 -> 13729 bytes
-rw-r--r--sys-libs/error-standalone/Manifest2
-rw-r--r--sys-libs/error-standalone/error-standalone-2.0-r1.ebuild (renamed from sys-libs/error-standalone/error-standalone-2.0.ebuild)8
3 files changed, 7 insertions, 3 deletions
diff --git a/sys-libs/Manifest.gz b/sys-libs/Manifest.gz
index bd5d97be144e..aa2f83062e31 100644
--- a/sys-libs/Manifest.gz
+++ b/sys-libs/Manifest.gz
Binary files differ
diff --git a/sys-libs/error-standalone/Manifest b/sys-libs/error-standalone/Manifest
index 6bd4c178ef29..cd1a95afc49b 100644
--- a/sys-libs/error-standalone/Manifest
+++ b/sys-libs/error-standalone/Manifest
@@ -1,5 +1,5 @@
DIST error-standalone-1.0.tar.gz 1947 BLAKE2B a6cc182caab990b841c708fd78e3539e2a0488355f7eb3e7cbe2bcf3d796c2b7c5046dd99defd005e155581363f858a4b52ac586d729a6e0d543c0d11cf1006f SHA512 4561f17896d411932fb02e8dc435b23e22c3874ccde668dcb5bc2c843383c4d774c45d295ce50607fcc32df0356f826792d7fbd14ecc768ad64b9021549135e3
DIST error-standalone-2.0.tar.gz 2329 BLAKE2B 2f2291056b46adbaeb655b39e57acd159b597add0a79ef8cbcd3a75b3de325975253338235e993f68973490aebe5eb5e1d3f88262770cb319e3b5aa9f1365a6b SHA512 bb5cf17dd58bc022b6f18b8044460ec1f32bbdda3ac9c9ccc71d4bdf0115cc1869ae8de85b3e66726ebbfb891d7b5f85b5eec8018d53643eeb81bcbc751fcf58
EBUILD error-standalone-1.0.ebuild 392 BLAKE2B 588f5a64c92746058e2588a36469b38afa265ebfd9419bfb727b2b1817bf9b9762db189f85fa3091766c378be138a0d5a2438d4efe893255f23f62e9f63f1998 SHA512 9de32eed063e8446d580e845f13af2af73099542ef4a215957b44d4e4242d6458e2a6fd8b02141b45d9b870c8584a0e42538c8b72d635f680fdc45d58cf91e85
-EBUILD error-standalone-2.0.ebuild 633 BLAKE2B 3290a9be188a09428be0fb1b45967ee71efc46e188686d6f461d947e5d4922c8ed5b2b95741dfe3ec259976207a984fb2e1907c4cb26feaa7327c26da2dc57e9 SHA512 39fb970abaab1d7cf53ab52bd50243ff5397ef2a2165678e49d1853543f3992c2eb8e05c400fe905cbecd8784a162ef9fa8f9ad1eb6b75182bade0bbb9d1e50d
+EBUILD error-standalone-2.0-r1.ebuild 693 BLAKE2B 9a3451c6bf9584aef3e3aab800bae1675c1879cc1a271dc967c8f6ff7962d1e3db319be59bfa8f32a6291401947d651b5a4c13f960f098e66384729865b10e97 SHA512 3252b6a33adf7c5a42b3f19063bdedadb6e43faa80383c622eea77ea53572b069d27c9ce02104281093895709ab525e1e5bf7a80c341774b0f9c5c192b512eef
MISC metadata.xml 410 BLAKE2B 75c853b9665a82c30c29f3aa0e9171fe2665ed2f7e4c1a7ccdd04258a07e4ef753ad01066934adccc3434aa52332b7007148c818b568335a2429bd8afc61d974 SHA512 b26adba8415ba084c079fabf29b966886bda8736165fbd9f0db13fe4da80e9be373ea7ed2d59e3b8c2b9a04eb84d8327f432c091c3ee936a82650a7983a7a483
diff --git a/sys-libs/error-standalone/error-standalone-2.0.ebuild b/sys-libs/error-standalone/error-standalone-2.0-r1.ebuild
index ed2a9dce4f91..39a273b1ada3 100644
--- a/sys-libs/error-standalone/error-standalone-2.0.ebuild
+++ b/sys-libs/error-standalone/error-standalone-2.0-r1.ebuild
@@ -1,21 +1,25 @@
-# Copyright 2024 Gentoo Authors
+# Copyright 2024-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="standalone <error.h> implementation intended for musl"
HOMEPAGE="https://hacktivis.me/git/error-standalone/"
SRC_URI="https://hacktivis.me/releases/error-standalone/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
RDEPEND="!sys-libs/glibc"
IUSE="static-libs"
src_compile() {
+ append-flags -fPIC
+
emake liberror.so $(usex static-libs liberror.a '')
}