summaryrefslogtreecommitdiff
path: root/sys-power/sispmctl/sispmctl-4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sys-power/sispmctl/sispmctl-4.1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sys-power/sispmctl/sispmctl-4.1.ebuild')
-rw-r--r--sys-power/sispmctl/sispmctl-4.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-power/sispmctl/sispmctl-4.1.ebuild b/sys-power/sispmctl/sispmctl-4.1.ebuild
new file mode 100644
index 000000000000..693002dbfb70
--- /dev/null
+++ b/sys-power/sispmctl/sispmctl-4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 systemd udev user
+
+DESCRIPTION="GEMBIRD SiS-PM control utility"
+HOMEPAGE="http://sispmctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sispmctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ virtual/libusb:0
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS="AUTHORS README ChangeLog"
+
+pkg_setup() {
+ enewgroup ${PN}
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-webless
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ ## install udev rules which make the device files writable
+ ## by the members of the group sispmctl
+ udev_dorules examples/60-sispmctl.rules
+
+ systemd_dounit examples/${PN}.service
+
+ einfo "Add users who may run ${PN} to the group '${PN}'"
+}