summaryrefslogtreecommitdiff
path: root/sys-process/anacron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /sys-process/anacron
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'sys-process/anacron')
-rw-r--r--sys-process/anacron/Manifest1
-rw-r--r--sys-process/anacron/anacron-2.3-r3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-process/anacron/Manifest b/sys-process/anacron/Manifest
index a731a5383fda..9ff54b0c7b19 100644
--- a/sys-process/anacron/Manifest
+++ b/sys-process/anacron/Manifest
@@ -4,5 +4,6 @@ AUX anacron.rc6 252 BLAKE2B 5237dbe878e9d5393f05b2671b6ee81461cd478cde37a2bf3527
AUX anacrontab 468 BLAKE2B 4f77a6759934e0e2693f3abeb9fe208de059d019906dc6c09160ac8b12e0c311d5f3414092c1cb6e62c947d950bf5fdf7990a6c351f4218f366ab2aaa4280c08 SHA512 f04850d22b459fe95bf5ccf594143f6fb02a1d29fc9cf36d2965a8b846920bc36b0d2d5665c5d6ac9828b904a4f30da49f62f6bedd51c75f548b981e056f097e
DIST anacron-2.3.tar.gz 24140 BLAKE2B 70fa2c716172a538b6810b65a4b80d8d8b70e8de7569856236f6386e30a3a77acc6b7aa11dfc3ce06aa432bc74009aa6dd44fd8d3b70f8585b979d0c5c596b98 SHA512 27bbbfad5bc35ddc68e4345c3a3acefd0a6f794aaba890f7c75ec42b2e4c4200fbb1667e75b2e344afb7722bdc9ba3dc5a7db66d3369808bc9f483ea3509849c
EBUILD anacron-2.3-r2.ebuild 1422 BLAKE2B 11d51a26fdfe62619f66584c6084e44ace99c029bb1fdd0228d55ff444bb82ed4a9733137d58fb511c4edaceb76e26eadc9057f60a42c73f666710a2a5ea53e5 SHA512 dc28aa765c65198333a740574140db23f778b28212e3b499485720f19315689bb75f8a3e75d64436bf1295741ae34b7e27daa970166196b8e2cc24b1a802c583
+EBUILD anacron-2.3-r3.ebuild 1444 BLAKE2B faea7ea4ef3206b2d500f5424bc245ff49c0efd8594fbdfb9c99f31874559a121745eb817e066291dfed3a20ef92a34a20b1897c20451be798426ea37b7b6246 SHA512 2ce3e597493c8ced6cacbe6e15a36903eb857a1b27cedc80c1cbb109436dfbe39bcf49b0bafdebd812d0d352c03f831fa5334d676f1ca7e6e033ab9eacacec20
EBUILD anacron-2.3-r4.ebuild 1443 BLAKE2B a7c39be2c6c9b85b59566d3dfcc151097c0524bbd69692ad7c63d48b36658a6c76cd95e124c5f0de3a18a1f0c5a8df9434b9da82f3f3b1b504cfabad89f61157 SHA512 82f32961b4d066682474eb3f6f26589000d746b9251ae2a826c0901d49869aed7c17096cf56d5ee6520bda49ac5ec1a6f2a2d9a8806f874454f5c4835eb5a1cb
MISC metadata.xml 244 BLAKE2B a650691e7c7b4c902aa2797645acba4fff4434a8b098b140e0eb711d81078e24df71625176cf489397639b117be475d38ede9697e60dd809ace97aafb2387c66 SHA512 991ccea1a22791aabec3cdf5cc996892d6c595263fd92b07a4b2b52a1ff32d96198aae09947b95b08e62542958225218890b08367ade7a07dc04ac332c5e4cfd
diff --git a/sys-process/anacron/anacron-2.3-r3.ebuild b/sys-process/anacron/anacron-2.3-r3.ebuild
new file mode 100644
index 000000000000..30f89d829732
--- /dev/null
+++ b/sys-process/anacron/anacron-2.3-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a periodic command scheduler"
+HOMEPAGE="http://anacron.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-process/cronbase"
+RDEPEND="${RDEPEND}
+ virtual/mta"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compile-fix-from-debian.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ sed -i \
+ -e '/^CFLAGS/{s:=:+=:;s:-O2::}' \
+ Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ #this does not work if the directory exists already
+ diropts -m0750 -o root -g cron
+ keepdir /var/spool/anacron
+
+ doman anacrontab.5 anacron.8
+
+ newinitd "${FILESDIR}"/anacron.rc6 anacron
+
+ dodoc ChangeLog README TODO
+
+ dosbin anacron
+
+ insinto /etc
+ doins "${FILESDIR}"/anacrontab
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
+ elog "at some early morning hour). This will make sure that jobs are run"
+ elog "when the systems is left running for a night."
+ echo
+ elog "Update /etc/anacrontab to include what you want anacron to run."
+
+ echo
+ elog "You may wish to read the Gentoo Linux Cron Guide, which can be"
+ elog "found online at:"
+ elog " https://wiki.gentoo.org/wiki/Cron"
+ fi
+}