summaryrefslogtreecommitdiff
path: root/sys-process/atop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /sys-process/atop/files
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'sys-process/atop/files')
-rw-r--r--sys-process/atop/files/atop-2.4.0-build.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-process/atop/files/atop-2.4.0-build.patch b/sys-process/atop/files/atop-2.4.0-build.patch
new file mode 100644
index 000000000000..73fd41691299
--- /dev/null
+++ b/sys-process/atop/files/atop-2.4.0-build.patch
@@ -0,0 +1,22 @@
+--- atop-2.4.0/Makefile
++++ atop-2.4.0/Makefile
+@@ -33,16 +33,16 @@
+
+ atop: atop.o $(ALLMODS) Makefile
+ $(CC) -c version.c
+- $(CC) atop.o $(ALLMODS) -o atop -lncurses -lz -lm -lrt $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) atop.o $(ALLMODS) -o atop $(shell ${PKG_CONFIG} --libs ncurses) -lz -lm -lrt
+
+ atopsar: atop
+ ln -sf atop atopsar
+
+ atopacctd: atopacctd.o netlink.o
+- $(CC) atopacctd.o netlink.o -o atopacctd $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) atopacctd.o netlink.o -o atopacctd
+
+ atopconvert: atopconvert.o
+- $(CC) atopconvert.o -o atopconvert -lz $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) atopconvert.o -o atopconvert -lz
+
+ netlink.o: netlink.c
+ $(CC) -I. -Wall -c netlink.c