summaryrefslogtreecommitdiff
path: root/sys-process/criu/files/2.2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/criu/files/2.2
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/criu/files/2.2')
-rw-r--r--sys-process/criu/files/2.2/criu-2.2-flags.patch13
-rw-r--r--sys-process/criu/files/2.2/criu-2.2-makefile.patch77
-rw-r--r--sys-process/criu/files/2.2/criu-2.2-no-git.patch16
3 files changed, 106 insertions, 0 deletions
diff --git a/sys-process/criu/files/2.2/criu-2.2-flags.patch b/sys-process/criu/files/2.2/criu-2.2-flags.patch
new file mode 100644
index 000000000000..97a806ba3414
--- /dev/null
+++ b/sys-process/criu/files/2.2/criu-2.2-flags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 037d38f..7c85403 100644
+--- a/Makefile
++++ b/Makefile
+@@ -97,8 +97,6 @@ endif
+ ifeq ($(DEBUG),1)
+ DEFINES += -DCR_DEBUG
+ CFLAGS += -O0 -ggdb3
+-else
+- CFLAGS += -O2 -g
+ endif
+
+ ifeq ($(GMON),1)
diff --git a/sys-process/criu/files/2.2/criu-2.2-makefile.patch b/sys-process/criu/files/2.2/criu-2.2-makefile.patch
new file mode 100644
index 000000000000..e4e856d8ba72
--- /dev/null
+++ b/sys-process/criu/files/2.2/criu-2.2-makefile.patch
@@ -0,0 +1,77 @@
+diff --git a/Makefile.install b/Makefile.install
+index b3f5551..2349107 100644
+--- a/Makefile.install
++++ b/Makefile.install
+@@ -6,23 +6,10 @@ BINDIR ?= $(PREFIX)/bin
+ SBINDIR ?= $(PREFIX)/sbin
+ MANDIR ?= $(PREFIX)/share/man
+ SYSTEMDUNITDIR ?= $(PREFIX)/lib/systemd/system/
+-LOGROTATEDIR ?= $(PREFIX)/etc/logrotate.d/
++LOGROTATEDIR ?= $(SYSCONFDIR)/etc/logrotate.d/
+ LIBDIR ?= $(PREFIX)/lib
+ INCLUDEDIR ?= $(PREFIX)/include/criu
+
+-#
+-# For recent Debian/Ubuntu with multiarch support.
+-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH 2>/dev/null)
+-ifneq "$(DEB_HOST_MULTIARCH)" ""
+- LIBDIR ?= $(PREFIX)/lib/$(DEB_HOST_MULTIARCH)
+-else
+- #
+- # For most other systems
+- ifeq "$(shell uname -m)" "x86_64"
+- LIBDIR ?= $(PREFIX)/lib64
+- endif
+-endif
+-
+ export BINDIR SBINDIR MANDIR SYSTEMDUNITDIR LOGROTATEDIR
+ export INCLUDEDIR LIBDIR DESTDIR PREFIX
+
+diff --git a/lib/Makefile b/lib/Makefile
+index f1c0821..3bef265 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -25,8 +25,12 @@ lib-c: c/$(CRIU_SO)
+ #
+ # Python bindings.
+ lib-py:
++ifeq ($(PYCRIU),yes)
+ $(call msg-gen, $@)
+ $(Q) $(MAKE) -C py all
++else
++ $(Q) echo "no py criu"
++endif
+ .PHONY: lib-py
+
+ all: lib-c lib-py
+@@ -43,7 +47,7 @@ clean:
+ $(Q) $(RM) -r build usr
+ .PHONY: clean
+
+-install: lib-c lib-py ../crit/crit c/criu.pc.in
++install: lib-c ../crit/crit c/criu.pc.in
+ $(E) " INSTALL " $(CRIU_SO)
+ $(Q) mkdir -p $(DESTDIR)$(LIBDIR)
+ $(Q) install -m 755 c/$(CRIU_SO) $(DESTDIR)$(LIBDIR)/$(CRIU_SO).$(CRIU_SO_VERSION_MAJOR).$(CRIU_SO_VERSION_MINOR)
+@@ -55,8 +59,6 @@ install: lib-c lib-py ../crit/crit c/criu.pc.in
+ $(Q) mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig
+ $(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)),' c/criu.pc.in > c/criu.pc
+ $(Q) install -m 644 c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig
+- $(E) " INSTALL " crit
+- $(Q) python ../scripts/crit-setup.py install --root=$(DESTDIR) --prefix=$(PREFIX) --record $(CRIT_SETUP_FILES)
+ .PHONY: install
+
+ uninstall:
+diff --git a/scripts/nmk/scripts/build.mk b/scripts/nmk/scripts/build.mk
+index bd40944..3cfbffa 100644
+--- a/scripts/nmk/scripts/build.mk
++++ b/scripts/nmk/scripts/build.mk
+@@ -87,7 +87,7 @@ builtin-name := $(strip $(builtin-name))
+
+ #
+ # Link flags.
+-ld_flags := $(strip $(LDFLAGS) $(ldflags-y))
++ld_flags := $(strip $(RAW_LDFLAGS) $(ldflags-y))
+
+ #
+ # $(obj) related rules.
diff --git a/sys-process/criu/files/2.2/criu-2.2-no-git.patch b/sys-process/criu/files/2.2/criu-2.2-no-git.patch
new file mode 100644
index 000000000000..0622225c2905
--- /dev/null
+++ b/sys-process/criu/files/2.2/criu-2.2-no-git.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile b/Makefile
+index 7c85403..20992ed 100644
+--- a/Makefile
++++ b/Makefile
+@@ -179,9 +179,9 @@ test: zdtm
+ # Generating tar requires tag matched CRIU_VERSION.
+ # If not found then simply use GIT's describe with
+ # "v" prefix stripped.
+-head-name := $(shell git tag -l v$(CRIU_VERSION))
++head-name := $(shell if [ -d ".git" ]; then git tag -l v$(CRIU_VERSION); fi)
+ ifeq ($(head-name),)
+- head-name := $(shell git describe)
++ head-name := $(shell if [ -d ".git" ]; then git describe; fi)
+ endif
+ tar-name := $(shell echo $(head-name) | sed -e 's/^v//g')
+ criu-$(tar-name).tar.bz2: