summaryrefslogtreecommitdiff
path: root/sys-process/cronie/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sys-process/cronie/files
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sys-process/cronie/files')
-rw-r--r--sys-process/cronie/files/cronie-1.5.6-autoconf-2.70.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-process/cronie/files/cronie-1.5.6-autoconf-2.70.patch b/sys-process/cronie/files/cronie-1.5.6-autoconf-2.70.patch
new file mode 100644
index 000000000000..958047784c5f
--- /dev/null
+++ b/sys-process/cronie/files/cronie-1.5.6-autoconf-2.70.patch
@@ -0,0 +1,38 @@
+From 44f6a0db3bac50deb11d15d3d847c41932afbfea Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 17 Mar 2021 17:44:38 +0100
+Subject: [PATCH] configure.ac: Don't use AM_CONDITIONAL inside an if statement
+
+or else configure might break:
+
+ configure: error: conditional "NEED_OBSTACK" was never defined.
+ Usually this means the macro was only invoked conditionally.
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8c575dd..b578431 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,11 +260,11 @@ if test "$enable_anacron" != no; then
+ dnl obstack.h is part of GLIBC and may not be present on other systems,
+ dnl eg. musl and AIX. There, we static link in our own copy.
+ AC_CHECK_HEADER(obstack.h, [have_obstack=yes], [have_obstack=no], [])
+- AM_CONDITIONAL([NEED_OBSTACK], [test "$have_obstack" = no])
+- if test "$have_obstack" = no; then
+- CPPFLAGS="$CPPFLAGS -I\$(top_srcdir)/obstack"
+- fi
+ fi
++AM_CONDITIONAL([NEED_OBSTACK], [test "$have_obstack" = no])
++AS_IF([test "$enable_anacron" != no && test "$have_obstack" = no], [
++ CPPFLAGS="$CPPFLAGS -I\$(top_srcdir)/obstack"
++])
+
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
+--
+2.31.0
+