summaryrefslogtreecommitdiff
path: root/sys-process/cronutils/cronutils-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 11:02:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 11:02:19 +0000
commit8c58ead574346296889d58006e1bf184da00be3a (patch)
treea7f2072c85179ee02c63febb294a7853dd137de1 /sys-process/cronutils/cronutils-1.10.ebuild
parentf9a583991092848eb54269744b512063a4d59de0 (diff)
gentoo auto-resync : 19:11:2023 - 11:02:18
Diffstat (limited to 'sys-process/cronutils/cronutils-1.10.ebuild')
-rw-r--r--sys-process/cronutils/cronutils-1.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-process/cronutils/cronutils-1.10.ebuild b/sys-process/cronutils/cronutils-1.10.ebuild
new file mode 100644
index 000000000000..d15e4328cafb
--- /dev/null
+++ b/sys-process/cronutils/cronutils-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities to assist running batch processing jobs"
+HOMEPAGE="https://github.com/google/cronutils"
+SRC_URI="https://github.com/google/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-version-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}