summaryrefslogtreecommitdiff
path: root/sys-process/fcron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-16 00:13:18 +0000
commitf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (patch)
treedd0f7da0455831dffb2cb662e7dae760f92e68ad /sys-process/fcron
parent770d63f36dbe1722e0ff9ab55eeca49986f01527 (diff)
gentoo auto-resync : 16:02:2025 - 00:13:18
Diffstat (limited to 'sys-process/fcron')
-rw-r--r--sys-process/fcron/Manifest2
-rw-r--r--sys-process/fcron/fcron-3.3.3.ebuild29
2 files changed, 11 insertions, 20 deletions
diff --git a/sys-process/fcron/Manifest b/sys-process/fcron/Manifest
index ccb05c9cecbf..e45a66727bc9 100644
--- a/sys-process/fcron/Manifest
+++ b/sys-process/fcron/Manifest
@@ -12,5 +12,5 @@ DIST fcron-3.3.3.tar.gz 620886 BLAKE2B a3332d39bf6b69e9e936cb9ec3e65778238566797
EBUILD fcron-3.3.1-r1.ebuild 7095 BLAKE2B 2b2ecc9eecdbb7f6362bcb0048fcacbb38c91f35263649473263c521c34c892141ddef55deccebe7dc8ea0c9099ae54aa515b56305f43f3804bee498cd1f904c SHA512 ed443144eae45377b1cee07f7a71bbe8a391a7bc13b6580bb3bcead7b3b480adf20de194cff836624c0e4755b14fc5f033fc0d068455f92d4833073ed96c929a
EBUILD fcron-3.3.1-r2.ebuild 7145 BLAKE2B e5962e3ba5b30c6503b5d0ac905bdeb7298485fc297dfb0efca8e171d6ef84027b002d3e92b18ab3b05f726226cbfcbf74974cf36c7ecec88722f5f909d3234e SHA512 4cda8d3058cc4f76ec98659f67e6d25043d0b38285c2f882b498a3da0471a01661b346daa0f66409c64f165be631d69bf169f4e3180244a4033d416fd4866b12
EBUILD fcron-3.3.2.ebuild 7013 BLAKE2B 3a98f22f0078605032336a1dd72f3e32fe49524955d969f8de96a11aaed2329313d7a40d0409062f3352229e6436a86122336212c275197a36a56fa33be373fc SHA512 25ce0dee6ef9f8546bf306252076ca2e347a6407613a1663de81dac6d81b6762e83462ab1f61335e437c20038e53af39151da81b1d92898b0402be8d9ff3e7db
-EBUILD fcron-3.3.3.ebuild 6973 BLAKE2B fa39f0bfb6e9689189ebe43c98df578cdafddcd2071626d9bd1a292f31712e75a92738230b5896432f4521346564f4ef64edd3813cd7ab0816bdc6d8818d2cef SHA512 9231129a7ee80c62eb10cd395ba6f17a7e42ba67190f7786264385f3d009e9a95925ddb47e7bc018875456734c872951a1f6de635cf9ceb13c4f1a64ac2589b3
+EBUILD fcron-3.3.3.ebuild 6858 BLAKE2B 19577b6434b42893f282462cb5a1e75568f422681a567c47b2bec3ce2ea8013c78feee0585e1950a272026c0b16511cf957bcfe71ee5b848defc193c3b247552 SHA512 bcdb91fd68dddf18cf13b6717089a8ff29abb0ce3bb5721eb1d2d1710b0bddafea6d07d52fc758dab86b7cad011c389f6ab91e961dcc80fe6217dc5b43a44f11
MISC metadata.xml 1320 BLAKE2B 169511184222d072788a2f66e329a149147d91003767e0c2a9a88db1d71a4c809b828563e2296960f132db96d4fe46996dbecdbb5e6badb3ec72d9998e111ad0 SHA512 6becadb18f88e7601111bace913a59e37c9337a4fea7442511872da351a03a7751fe38caa1eb5872a16d67069cba5a04388fe5c872dd2cfa79342fdb9f42ac7c
diff --git a/sys-process/fcron/fcron-3.3.3.ebuild b/sys-process/fcron/fcron-3.3.3.ebuild
index c9db91dc9ba3..9b4c34d2e31e 100644
--- a/sys-process/fcron/fcron-3.3.3.ebuild
+++ b/sys-process/fcron/fcron-3.3.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WANT_AUTOMAKE="none"
-inherit autotools cron flag-o-matic pam systemd user-info
+inherit autotools cron eapi9-ver flag-o-matic pam systemd user-info
MY_PV="${PV/_beta/}"
MY_P="${PN}-${MY_PV}"
@@ -192,24 +192,15 @@ pkg_postinst() {
elog " # emerge --config ${CATEGORY}/${PN}"
elog ""
elog "to install the default systab on this system."
- else
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "3.2.1" -gt ${v}; then
- # This is an upgrade
-
- elog "fcron's default systab was updated since your last installation."
- elog "You can use"
- elog ""
- elog " # emerge --config ${CATEGORY}/${PN}"
- elog ""
- elog "to re-install systab (do not call this command before you"
- elog "have merged your configuration files)."
-
- # Show this elog only once
- break
- fi
- done
+ elif ver_replacing -lt "3.2.1"; then
+ # This is an upgrade
+ elog "fcron's default systab was updated since your last installation."
+ elog "You can use"
+ elog ""
+ elog " # emerge --config ${CATEGORY}/${PN}"
+ elog ""
+ elog "to re-install systab (do not call this command before you"
+ elog "have merged your configuration files)."
fi
if ! use system-crontab; then