summaryrefslogtreecommitdiff
path: root/sys-process/htop/htop-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-18 13:51:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-18 13:51:55 +0000
commit64602f81dd4ecc257e8c5139f42b902d3555ea78 (patch)
tree85e7aaf8930e26f19c497d5a9aaa2df1881f4a6d /sys-process/htop/htop-9999.ebuild
parentf8730c9e91ed2ce341e231c5adffb5f003f77678 (diff)
gentoo auto-resync : 18:12:2023 - 13:51:55
Diffstat (limited to 'sys-process/htop/htop-9999.ebuild')
-rw-r--r--sys-process/htop/htop-9999.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/sys-process/htop/htop-9999.ebuild b/sys-process/htop/htop-9999.ebuild
index 308bba2b8c3c..95b4f940ef01 100644
--- a/sys-process/htop/htop-9999.ebuild
+++ b/sys-process/htop/htop-9999.ebuild
@@ -3,11 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
# We avoid xdg.eclass here because it'll pull in glib, desktop utils on
# htop which is often used on headless machines. bug #787470
-inherit linux-info optfeature python-any-r1 xdg-utils
+inherit linux-info optfeature xdg-utils
DESCRIPTION="Interactive process viewer"
HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
@@ -39,18 +37,12 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-pkg_setup() {
- python-any-r1_pkg_setup
- linux-info_pkg_setup
-}
-
src_prepare() {
default