summaryrefslogtreecommitdiff
path: root/sys-process/memwatch/memwatch-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/memwatch/memwatch-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/memwatch/memwatch-0.1.0.ebuild')
-rw-r--r--sys-process/memwatch/memwatch-0.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.1.0.ebuild b/sys-process/memwatch/memwatch-0.1.0.ebuild
new file mode 100644
index 000000000000..7111f876e715
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://bitbucket.org/PascalRD/memwatch/"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}