summaryrefslogtreecommitdiff
path: root/sys-process/procenv/procenv-0.51.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /sys-process/procenv/procenv-0.51.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'sys-process/procenv/procenv-0.51.ebuild')
-rw-r--r--sys-process/procenv/procenv-0.51.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/procenv/procenv-0.51.ebuild b/sys-process/procenv/procenv-0.51.ebuild
new file mode 100644
index 000000000000..2f1408191151
--- /dev/null
+++ b/sys-process/procenv/procenv-0.51.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ )
+
+ default
+ eautoreconf
+}