summaryrefslogtreecommitdiff
path: root/sys-process/unixtop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sys-process/unixtop/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sys-process/unixtop/files')
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch3
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-recent-linux.patch13
-rw-r--r--sys-process/unixtop/files/unixtop-3.8_beta1-winch-segfault.patch31
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch
index a2da4b47da6a..476093c7e565 100644
--- a/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-ncurses.patch
@@ -1,5 +1,6 @@
* check ncurses first, such that we only link agains (system) termcap if
necessary (never the case in prefix) -- grobian@gentoo.org
+* check tinfo in case of ncurses[tinfo] -- jer@gentoo.org
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +9,7 @@
# -lmld -lmach
AC_CHECK_LIB(mach, vm_statistics)
-AC_SEARCH_LIBS(tgetent, termcap curses ncurses)
-+AC_SEARCH_LIBS(tgetent, ncurses curses termcap)
++AC_SEARCH_LIBS(tgetent, ncurses tinfo curses termcap)
AC_CHECK_LIB(m, exp)
# check for libraries required by extension
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-recent-linux.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-recent-linux.patch
new file mode 100644
index 000000000000..f3777dacb80a
--- /dev/null
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-recent-linux.patch
@@ -0,0 +1,13 @@
+grab PAGE_SHIFT from a location where it is defined nowadays
+
+--- a/machine/m_linux.c
++++ b/machine/m_linux.c
+@@ -68,7 +68,7 @@
+ #include <sys/vfs.h>
+
+ #include <sys/param.h> /* for HZ */
+-#include <asm/page.h> /* for PAGE_SHIFT */
++#include <sys/user.h> /* for PAGE_SHIFT */
+
+ #if 0
+ #include <linux/proc_fs.h> /* for PROC_SUPER_MAGIC */
diff --git a/sys-process/unixtop/files/unixtop-3.8_beta1-winch-segfault.patch b/sys-process/unixtop/files/unixtop-3.8_beta1-winch-segfault.patch
new file mode 100644
index 000000000000..e00e4052eb4f
--- /dev/null
+++ b/sys-process/unixtop/files/unixtop-3.8_beta1-winch-segfault.patch
@@ -0,0 +1,31 @@
+https://sourceforge.net/p/unixtop/patches/22/
+
+diff -u top-3.8beta1/top.c top-3.8beta1-rivoreo-r1/top.c
+--- top-3.8beta1/top.c 2008-05-07 11:41:39.000000000 +0800
++++ top-3.8beta1-rivoreo-r1/top.c 2017-01-15 18:32:50.000000000 +0800
+@@ -257,14 +258,14 @@
+ }
+
+ void
+-set_signals()
++set_signals(int set_winch)
+
+ {
+ (void) set_signal(SIGINT, sig_leave);
+ (void) set_signal(SIGQUIT, sig_leave);
+ (void) set_signal(SIGTSTP, sig_tstop);
+ #ifdef SIGWINCH
+- (void) set_signal(SIGWINCH, sig_winch);
++ if(set_winch) set_signal(SIGWINCH, sig_winch);
+ #endif
+ }
+
+@@ -905,7 +906,7 @@
+ screen_init();
+
+ /* set the signal handlers */
+- set_signals();
++ set_signals(gstate->interactive);
+
+ /* longjmp re-entry point */
+ /* set the jump buffer for long jumps out of signal handlers */