summaryrefslogtreecommitdiff
path: root/sys-process/xjobs/xjobs-20200726.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sys-process/xjobs/xjobs-20200726.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sys-process/xjobs/xjobs-20200726.ebuild')
-rw-r--r--sys-process/xjobs/xjobs-20200726.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/xjobs/xjobs-20200726.ebuild b/sys-process/xjobs/xjobs-20200726.ebuild
new file mode 100644
index 000000000000..ce8701c8d06e
--- /dev/null
+++ b/sys-process/xjobs/xjobs-20200726.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Reads commands line by line and executes them in parallel"
+HOMEPAGE="https://www.maier-komor.de/xjobs.html"
+SRC_URI="https://www.maier-komor.de/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="sys-devel/flex"
+
+# The ncurses/terminfo libraries are used to provide color and status
+# support; but, they're detected and enabled automagically by the build
+# system. Thus it would do no good to hide them behind a USE flag that
+# can't be turned off.
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/xjobs-20200726-command-v.patch"
+ "${FILESDIR}/xjobs-20200726-dont-page-tests.patch"
+)
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+}