summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-14 06:41:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-14 06:41:38 +0000
commit6e1fc32629c46e29012a7e22b07085307d65ac96 (patch)
tree3a10753f21f24b2f29706bc4c28b1074119343d8 /sys-process
parent4b1d73e089a436406c89fadc33638314981c44e6 (diff)
gentoo auto-resync : 14:01:2025 - 06:41:37
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10285 -> 10295 bytes
-rw-r--r--sys-process/iotop-c/Manifest2
-rw-r--r--sys-process/iotop-c/iotop-c-1.27.ebuild43
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 8697190a1efb..406ad72600c0 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index c275ad506f91..94012039bed6 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1,3 +1,5 @@
DIST iotop-c-1.26.tar.gz 139536 BLAKE2B 90bb3db7dd3b05604fa5368a881434eac06509921447fd53bda7e7291e2c823f82f9015f0c16c516dcfa7c8ee6198466b8634eaf1b111b4f911645b97fc2634f SHA512 47246bc025c396bcd7569bd19d52079701e3b86ab239ac3db1d1386f358f6e95a63d7bad8c1d0552fb61315a9db282967c65e110703863ae71fa6260b775942b
+DIST iotop-c-1.27.tar.gz 142334 BLAKE2B 80e8ff6d90d325533a9097596dd0353d26214e2302931d0268a2d8f491a9e531d795ba450eac2b0f4bea7beb88317053f8d23308fcdbf52570991255afb81ea0 SHA512 55a93e2f3c6aaeb46ca219a77e64706083b8746d1299e8ab576780a2c6a17eb5612c1280531432748afb90ded5e6677149301ea2641b4f77cd3a2d91700b1fbb
EBUILD iotop-c-1.26.ebuild 903 BLAKE2B c200bdcc7f9a50ec030edc4a4a7d822b191d837539587b58799545d9c0755ef25cc8c1fa2d98c13bbebef6005f49bf6123c615b620283895330d6f7d2915da11 SHA512 5975ffe94ba459dcaff179e6923f986a5dee122ffdde3444afc9c65c96a852cc5edc683eccebd5913036a54a20796b03ff067512365b9ce88022cb9626e5c959
+EBUILD iotop-c-1.27.ebuild 909 BLAKE2B ae1f65f82f575df8724f4830e27a15a831c6d744315568e527b998e73ec6d5189c12c9cd53b1dde3af72bcc864988ae56a63ea7496acfdc63f3d372cfade5f9a SHA512 341f0e91b8c00cc548637d3a029e95d7cc2a4615aee65f3b4caacef208956073f5bad82780c80b7d46037bda2f802b6a84d97ba59950939883dd6dec259be59c
MISC metadata.xml 1377 BLAKE2B 1b0e762f6677fd063044d1ad811fda5c95f64b36a51310dd3d9d0e652d9d671fe255a9cfa312d299369b19d4206723aa5010994ff6e20bf1b67be92432cb4350 SHA512 c5eee7ec3b5711666029d57eb84319e3f89373d7f73d067d1b990ecfcc6d98625966fb781ea3a47894ea078cfca40fc5f03a8d70dd83f7c93b8a77a6e14d2de0
diff --git a/sys-process/iotop-c/iotop-c-1.27.ebuild b/sys-process/iotop-c/iotop-c-1.27.ebuild
new file mode 100644
index 000000000000..4a1fa565f4d6
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.27.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ !sys-process/iotop
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}