summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-24 00:31:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-24 00:31:53 +0000
commit72e4c0bc86eea366d063d15b3d5611e8f82ffd05 (patch)
treebe4116935e605807f4a03de97c876e050718881a /sys-process
parentadd1c3acddd7a3f49fdb230135725463d2662921 (diff)
gentoo auto-resync : 24:03:2025 - 00:31:53
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10307 -> 10306 bytes
-rw-r--r--sys-process/tini/Manifest2
-rw-r--r--sys-process/tini/files/tini-0.19.0-cmake4.patch10
-rw-r--r--sys-process/tini/tini-0.19.0-r2.ebuild71
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 96c38adc9387..cb91f74a023b 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/tini/Manifest b/sys-process/tini/Manifest
index 24d4514b9116..47d3560cfb96 100644
--- a/sys-process/tini/Manifest
+++ b/sys-process/tini/Manifest
@@ -1,4 +1,6 @@
+AUX tini-0.19.0-cmake4.patch 243 BLAKE2B 5ddad83d460dfc6d67d6f5c379e8844e97874d121870f999fc63fff569fa999def65161806e6db4fa72d40ada083d9d9718e5abcd7a148bf4a708583f328159a SHA512 6b521857909b553fd9ba54d39b8ce0980a23ed0b15a8fde9458efeed9bf458ca6e81582490d1f8ee061712957bc54c828099adb958db7fdad982f7190072a3b1
AUX tini-0.19.0-musl-basename.patch 479 BLAKE2B 16ebb93dfb59fd5808b820eec1b92034f1eef4015a9107b969a661cf4b70eb590cfcc799a129937ba39295bcfe0fae0acd76eaf302790bd0010e88df698abae9 SHA512 69eef3220544f0447f05f4658616a42129ca67d0c89d051602e8fcd2003db639062cab2a4d277583d61558bba3834b47f4b5aa6796d24f308b9ccadf0df7fe41
DIST tini-0.19.0.tar.gz 32369 BLAKE2B 5d86f6299b92152063974e6ecd347e1a2ba90f0188f2a702ddb6c814fc1c9723062481fe560caa89e9f74883017ee833566adf1eb1f11fe625671eced47f3296 SHA512 1fa85b56e2c6085ea474f251928e7a40510d92aeef60b3c145b0496969c1b5df86835d143cb91ef5b4bf4da63fa8a56947cc39a4276e4b72faa57276d432b292
EBUILD tini-0.19.0-r1.ebuild 1696 BLAKE2B dd334cead719528caa4d1747864be3ceaaeb45e3ad7983b4be2a96122dd700b28cacde12da3fb99f6a98f5c44090b34d21c3c6e8f968cb1acae8c6ec9ac1104a SHA512 50dcc769934811ab51242376cbcd66307ead4c2e5b6194e17b54bbf6c25fced13cf83df45a9714127660512ce85c34051e362078b9e66f1aa89494d8c412b644
+EBUILD tini-0.19.0-r2.ebuild 1731 BLAKE2B 1dbcffc4880dff692e6325d4d642e8f4d94e0c4859becb28b5216d35699ebd99a43534ac38bf6dd8f5560236a729207b11d587001c5bf3889d0f945c4fcfa6b3 SHA512 897bafff38705d2b0103f207c06060c39285557688ebeb96db69e9fbd0e4d85d5c29990c83c92a668559fb5ba7dfabcc32e5e15b31681dff94f0b885889f505e
MISC metadata.xml 559 BLAKE2B b04eef0b3d03c84577580329665c00e152b7385717e45f9da71dd805813abff31736bd6c356c7c8bb7306811edcdc5727a41a6ebf16280b6175c5d9f9aec1971 SHA512 fd54927b31b2bb4415e67d12bc4332ce25c5ec7169f72b214a97079efe45e3b5014acc1bef5a4eb8cc711d2d37de666647210b612211452d3dd178c5bc1994e6
diff --git a/sys-process/tini/files/tini-0.19.0-cmake4.patch b/sys-process/tini/files/tini-0.19.0-cmake4.patch
new file mode 100644
index 000000000000..f5f5f37b3d4c
--- /dev/null
+++ b/sys-process/tini/files/tini-0.19.0-cmake4.patch
@@ -0,0 +1,10 @@
+Version bump for compatibility with CMake 4
+https://bugs.gentoo.org/951903
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required (VERSION 2.8.0)
++cmake_minimum_required (VERSION 3.5.0)
+ project (tini C)
+
+ # Config
diff --git a/sys-process/tini/tini-0.19.0-r2.ebuild b/sys-process/tini/tini-0.19.0-r2.ebuild
new file mode 100644
index 000000000000..2b6ba667a122
--- /dev/null
+++ b/sys-process/tini/tini-0.19.0-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+# guard against forgetfulness, https://bugs.gentoo.org/795936
+GIT_COMMIT_0190="de40ad007797e0dcd8b7126f27bb87401d224240"
+GIT_COMMIT="GIT_COMMIT_${PV//./}"
+GIT_COMMIT="${!GIT_COMMIT}"
+
+DESCRIPTION="A tiny but valid init for containers"
+HOMEPAGE="https://github.com/krallin/tini"
+SRC_URI="https://github.com/krallin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~x86"
+IUSE="+args +static"
+
+PATCHES=(
+ "${FILESDIR}/${P}-musl-basename.patch"
+ "${FILESDIR}/${P}-cmake4.patch"
+ )
+
+src_prepare() {
+
+ [[ -z ${GIT_COMMIT} ]] && die "forgetful maintainer! please define GIT_COMMIT_${PV//./} on bump"
+
+ cmake_src_prepare
+
+ local sed_args=(
+ # Do not strip binary
+ -e 's/-Wl,-s")$/")/'
+
+ # Remove -Werror and -pedantic-errors in order to allow macro
+ # redefinition, so that CFLAGS="-U_FORTIFY_SOURCE" does not
+ # trigger an error due to add_definitions(-D_FORTIFY_SOURCE=2)
+ # in CMakeLists.txt (bug 626438).
+ -e "s/ -Werror / /"
+ -e "s/ -pedantic-errors / /"
+ )
+
+ sed -i "${sed_args[@]}" \
+ -e "s/git.*status --porcelain.*/true/" \
+ -e "s/git.*log -n 1.*/true/" \
+ -e "s/git.\${tini_VERSION_GIT}/git.${GIT_COMMIT}/" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use args || mycmakeargs+=(-DMINIMAL=ON)
+
+ cmake_src_configure
+}
+
+src_compile() {
+ append-cflags -DPR_SET_CHILD_SUBREAPER=36 -DPR_GET_CHILD_SUBREAPER=37
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ if use static; then
+ mv "${ED}"/usr/bin/{${PN}-static,${PN}} || die
+ else
+ rm "${ED}"/usr/bin/${PN}-static || die
+ fi
+}