summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-28 22:42:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-28 22:42:59 +0000
commitfc4ad6e568738af8995c2e87896c671c39eb8c72 (patch)
treeb56fb204081c089b8a979d01e8badc2c819f8cf0 /sys-process
parent417348c68a53a9317b6afbf343381518a405f682 (diff)
gentoo auto-resync : 28:01:2025 - 22:42:58
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10301 -> 10304 bytes
-rw-r--r--sys-process/numad/Manifest2
-rw-r--r--sys-process/numad/numad-9999.ebuild17
3 files changed, 11 insertions, 8 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index bd2c2e882742..bdc9f96aee12 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/numad/Manifest b/sys-process/numad/Manifest
index db2c0958a345..cb61464826b3 100644
--- a/sys-process/numad/Manifest
+++ b/sys-process/numad/Manifest
@@ -12,5 +12,5 @@ DIST numad-0.5_p20180531.tar.gz 29797 BLAKE2B 455feba97685b0f0c6dd8ce10227d397b1
EBUILD numad-0.5-r3.ebuild 1126 BLAKE2B 3f3d1d6c789a08d8dccfa4aa787ab8a33b2d26411438adabd5dc514ab00880f8bba7128d4ed2bebaba45b7f353287ca14be95e8c6a4e77ef07c4869d7ae06697 SHA512 5fd9fd0c7f0957dbf501d112069c014eb05e942f623ba6e5f1e9257aa94d7399f77fe56017adfbb900fed9486e0356413024506dd26e75890f00398a7611eab5
EBUILD numad-0.5-r4.ebuild 1176 BLAKE2B 945aed6353b8fcb0b4c0e146295c8ae7fca184159accce1ee421c71b3870c58af3bea59dafa99172ac2dd6ad3e44e75af1200dcde6a492f911ae428e82723f68 SHA512 e865c8dde6b328540b7f2d4ae10ae7897abf5193b57faea37a3afeac188b9f7c360d495ae1fba21f1435316b7312c2bc0871841dfc7c48903cf48a235f7cd42d
EBUILD numad-0.5_p20180531-r2.ebuild 1516 BLAKE2B 45352efa1635a15f9b29522c198a0c3e3e233fca1cf5b21b5a5b5b551aa0da7284414b53925738af2a4edda2cedc0642bf15647108b41c3600b1d54686ec36ef SHA512 0e488f9a237fa717c30f4301c150597b26f8ef5c09e12b5b085486411636e235498d7334af92feac4af556ee69a74b8646c1b54ce450f1890b09edab95aad9d2
-EBUILD numad-9999.ebuild 1290 BLAKE2B c5a669b3c7f990ecc53c901c41a748c6e77cabd4b284a08fa7692dac20cc608383b8cbec7a7174fe36c79b8ed35d407ed436634ea1be5896aeeafaeeba869a74 SHA512 0b44f8a664bdb5af054e9ff5712884a6905cd4e6b1bc58869e134c551248920e0924fbd5281cbbacd2dd64c22854583daa1e2e6b2b366181786b43d5a3ec1d90
+EBUILD numad-9999.ebuild 1363 BLAKE2B cf5c3dcdb777dade0986ec2aa2c97d6c72b069fe2494eac8e58478d6a4b663a347eb88100e5b6a3023b4c3ea9fe63a3608c89d4f01bf7fd757ad98f3c752f984 SHA512 07e5ed9829d43723c714502b9b93c3584952335c5db89ada7e93a34f34ee9f8ce37a085412afdf467cdf8527cd3f8386054132069a39c4ba4fc8d83edb9a95e5
MISC metadata.xml 254 BLAKE2B f3a9f843cf94243d1129711770df727fcdc8808bca829ef784819cab6f5410dfa463cfed85182f8228c7de796a674dd602653ad3ef817a62c0c3e7198b23befe SHA512 b9fcd3084a7e197f6138e1ce8b0eff99c4c203c37a7d5c40de207040ba1501ef0e5b2f4e00216a567037bcd6d3394fdec6ff587484c9ba2fca9d04f431733b7c
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index fffe3f4192c1..453dd705cae3 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic linux-info systemd toolchain-funcs
+inherit linux-info systemd toolchain-funcs
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://pagure.io/numad.git"
@@ -25,13 +25,16 @@ SLOT="0"
CONFIG_CHECK="~NUMA ~CPUSETS"
+PATCHES=(
+ # https://pagure.io/numad/pull-request/3
+ "${FILESDIR}/${PN}-0.5-fix-sparse-node-ids.patch"
+
+ # from debian/ubuntu: https://sources.debian.org/patches/numad
+ "${FILESDIR}/${PN}-0.5-fix-build-for-no-NR-migrate-pages.patch"
+)
+
src_configure() {
tc-export AR CC RANLIB
-
- # FIXME: https://bugs.gentoo.org/890985
- # temp workaround
- filter-flags -D_FORTIFY_SOURCE=3
- append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
}
src_compile() {