summaryrefslogtreecommitdiff
path: root/virtual/opencl/opencl-3-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
commitbb59556b3302a941db4630613c604644d5f7a617 (patch)
tree42e60b7ae227b0fe3af52dfac08d59653066a2db /virtual/opencl/opencl-3-r4.ebuild
parent3cd09a18bad26aad2645241b868755cfdf41b6ae (diff)
gentoo auto-resync : 11:04:2025 - 08:43:58HEADmaster
Diffstat (limited to 'virtual/opencl/opencl-3-r4.ebuild')
-rw-r--r--virtual/opencl/opencl-3-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/virtual/opencl/opencl-3-r4.ebuild b/virtual/opencl/opencl-3-r4.ebuild
new file mode 100644
index 000000000000..47c50894d7c5
--- /dev/null
+++ b/virtual/opencl/opencl-3-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenCL API"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86"
+
+RDEPEND="
+ >=dev-libs/opencl-icd-loader-2023.02.06[${MULTILIB_USEDEP}]
+"
+
+pkg_postinst() {
+ elog
+ elog "In order to take advantage of OpenCL you will need a runtime for your hardware."
+ elog "Currently included in Gentoo are:"
+ elog
+ elog " * open:"
+ elog " - dev-libs/intel-compute-runtime - integrated Intel GPUs from Gen12 onwards. 64-bit only;"
+ elog " - dev-libs/intel-compute-runtime:legacy - integrated Intel GPUs from Gen5 up to Gen11. 64-bit only;"
+ elog " - dev-libs/pocl - to run OpenCL programs on your CPU, if you do not have a supported GPU;"
+ elog " - dev-libs/rocm-opencl-runtime - AMD GPUs supported by the amdgpu kernel driver. 64-bit only;"
+ elog " - media-libs/mesa[opencl] - some older AMD GPUs; see [1]. 32-bit support;"
+ elog
+ elog " * proprietary:"
+ elog " - dev-libs/amdgpu-pro-opencl - AMD Polaris GPUs. 32-bit support;"
+ elog " - dev-util/intel-ocl-sdk - Intel CPUs (*not* GPUs). 64-bit only;"
+ elog " - x11-drivers/nvidia-drivers - Nvidia GPUs; specific package versions"
+ elog " required for older devices [2]. 32-bit support."
+ elog
+ elog " [1] https://dri.freedesktop.org/wiki/GalliumCompute/"
+ elog " [2] https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/"
+ elog
+}