summaryrefslogtreecommitdiff
path: root/virtual/python-funcsigs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /virtual/python-funcsigs
reinit the tree, so we can have metadata
Diffstat (limited to 'virtual/python-funcsigs')
-rw-r--r--virtual/python-funcsigs/Manifest4
-rw-r--r--virtual/python-funcsigs/metadata.xml8
-rw-r--r--virtual/python-funcsigs/python-funcsigs-0-r1.ebuild17
-rw-r--r--virtual/python-funcsigs/python-funcsigs-1.ebuild17
4 files changed, 46 insertions, 0 deletions
diff --git a/virtual/python-funcsigs/Manifest b/virtual/python-funcsigs/Manifest
new file mode 100644
index 000000000000..da74e5ad8e21
--- /dev/null
+++ b/virtual/python-funcsigs/Manifest
@@ -0,0 +1,4 @@
+EBUILD python-funcsigs-0-r1.ebuild 527 SHA256 572645d1be52b8c26329073a84faf9131045ddf7bc7f8f423d21d6580861e3d8 SHA512 200909ef3ee53c3bbe72f62b9e210636903003941cbf5f12af0b4ece905d2b90aa4b8370467be2f2dfe67a129d12388ddbb13f1839124935b4616464a4673c4f WHIRLPOOL ef28574291e5c4bd0e0905922ab8f0316d83fb4f60a1870b005e5df6d72c8cfe530fb52b9b1c4f3235a4fe6911a94e7a5a22aae9ee49cea600869d2dc38f475b
+EBUILD python-funcsigs-1.ebuild 548 SHA256 1fe5a54f49cfb60cd8b1ff8e43c064109cb1d1deab29d8bdd4087cf3cfe6d3c9 SHA512 59fc5caf33aa95cbe7836182b9739939cbb65f393c9aa34eda0573ec42172c73a9cae343830f3fb03db65573f014194a7f35d06c4aa9bfc4df16dcfdc16706c5 WHIRLPOOL 31c7b92c2c1d4af0690a49c3d398bece7a89ac4794ba0d9db56161c575eca739855ee4ff1df96989d6f5edd5166517b7bd7fdd182da2c3c77a9977d0d8886dae
+MISC ChangeLog 2186 SHA256 86ebdb15e02949884cbf3df91943dbf1c55e3e8bd997fe2451628596c993c040 SHA512 304cd3bfd81aa87ee85e8eae885eed26a8269cbe9aceae4a52891010042882c7a77aaa46df7bd77b7f2a0210d1f0b7a565f8e46d51ad2f25fe952ecd975bcad2 WHIRLPOOL fb43f31d494de459ae197248e83d7a1db0b51ae822a3a50c9030d6713fe5a55fe0f68c598dc39328d413cd07f32e7ce3fd73f06d5aef4c6eb67db179d3957919
+MISC metadata.xml 246 SHA256 634432e12556106844e569b7ff16962881c6e70887e6fc9650bdd82deb51a834 SHA512 3245fb694492b2f698fb63aac02e66fb8a94fe35eabda45df4790bec043a1ea552e112315334001902f070093bb73e7b741aa3004757404aed97ebdb86cc9fbc WHIRLPOOL 869ef1c8e23bdae0a11b44ccf38ddec23f0dc0ae2573bc83ccbe2d8a2c6bf5a3f9c3c52149aa2e3690dd66f7fc7ec498f2eb6b9d338440fb54c12d5ac0b9fb7a
diff --git a/virtual/python-funcsigs/metadata.xml b/virtual/python-funcsigs/metadata.xml
new file mode 100644
index 000000000000..e24dd86faa2a
--- /dev/null
+++ b/virtual/python-funcsigs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-funcsigs/python-funcsigs-0-r1.ebuild b/virtual/python-funcsigs/python-funcsigs-0-r1.ebuild
new file mode 100644
index 000000000000..d8fa5255fd09
--- /dev/null
+++ b/virtual/python-funcsigs/python-funcsigs-0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362 (py3.3 variant)"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/funcsigs' python2_7 pypy pypy3 )"
diff --git a/virtual/python-funcsigs/python-funcsigs-1.ebuild b/virtual/python-funcsigs/python-funcsigs-1.ebuild
new file mode 100644
index 000000000000..9673bfe352d1
--- /dev/null
+++ b/virtual/python-funcsigs/python-funcsigs-1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362 (py3.6 variant)"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '>=dev-python/funcsigs-1' python2_7 python3_{3,4,5} pypy{,3} )"