summaryrefslogtreecommitdiff
path: root/virtual/python-typing/python-typing-0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 19:47:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 19:47:04 +0100
commit83c20bc401b9e577248523c6555493e36a100a41 (patch)
tree5b6c7aff501ae2eb85988f2a702484e1474b0e15 /virtual/python-typing/python-typing-0-r1.ebuild
parentf70601e0934acd62f6c5d06c5ede4cc607179514 (diff)
gentoo resync : 14.07.2018 (1st step)
Diffstat (limited to 'virtual/python-typing/python-typing-0-r1.ebuild')
-rw-r--r--virtual/python-typing/python-typing-0-r1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-typing/python-typing-0-r1.ebuild b/virtual/python-typing/python-typing-0-r1.ebuild
new file mode 100644
index 000000000000..c31dcbb43237
--- /dev/null
+++ b/virtual/python-typing/python-typing-0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python typing module"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' \
+ 'python2*' python3_4 pypy)"