summaryrefslogtreecommitdiff
path: root/virtual
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-15 06:52:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-15 06:52:13 +0000
commit9f7759b3b1be5a3bc7794010a8ebf9334f017d2f (patch)
treefa4e093c6694ec0590cbbd9a7b86c1edddc43d72 /virtual
parentac35def7deb4a1eecfad26f0eb5907170b2ee5d7 (diff)
gentoo auto-resync : 15:11:2022 - 06:52:13
Diffstat (limited to 'virtual')
-rw-r--r--virtual/Manifest.gzbin28594 -> 28597 bytes
-rw-r--r--virtual/rust/Manifest2
-rw-r--r--virtual/rust/rust-1.64.0-r1.ebuild22
-rw-r--r--virtual/rust/rust-1.65.0-r1.ebuild23
4 files changed, 47 insertions, 0 deletions
diff --git a/virtual/Manifest.gz b/virtual/Manifest.gz
index e03ee4b92152..c4bc7ca542ec 100644
--- a/virtual/Manifest.gz
+++ b/virtual/Manifest.gz
Binary files differ
diff --git a/virtual/rust/Manifest b/virtual/rust/Manifest
index 8742e8936bfe..0dbc33dec9d0 100644
--- a/virtual/rust/Manifest
+++ b/virtual/rust/Manifest
@@ -1,3 +1,5 @@
+EBUILD rust-1.64.0-r1.ebuild 594 BLAKE2B 1603bccebaab9ef50f942ae187112c25ca2a44d603f455f62cc45b9c2e3ad8e977e5fccfd3f400a7ee688f54c7b9ab4fc7f3889cdfa4729ca9ec6d74e544047a SHA512 305a28f9d1f945491eebdeea385971ec66827006b294f57806af8a0aae2fc7b4c6e3f8b16fe81958050b69d9401e6586bed2d6b987a3ce904273a2c665b30524
EBUILD rust-1.64.0.ebuild 416 BLAKE2B 6a14e5f7411bf5ab0e38b9649d1ad915d2ade4628f6012f384deec0fd1bfd3a23574dfd226aa6880baba52b8f6d1da5a1d07cfea9c5ff680c0787c8a9822c9c1 SHA512 42973ab4be0d7b1f6a6299c3a547fd1960cf6727f28d9cfec8abcc55cb565965dbe02a84414e82dc7ad766a92b9b819e8697836fb60bea88a7616f9eb0dbf06d
+EBUILD rust-1.65.0-r1.ebuild 609 BLAKE2B 56fbd7d44df9b111304f03150d966e946beef7a13eaaf28cc2d9de4ffdbaa316b3c1259a7a52a234bf57afdacfaf1abe9b296671b2b62956d07827cca2a775e2 SHA512 ea27be3e8ef4076e617f3b6d45d7abab488c30b8a4dfea267f8ddbab7c69b1d8efdfb347a297ddb9101ed097b64cb93ed26f1f33aeb250b8085cfc74d83eec61
EBUILD rust-1.65.0.ebuild 430 BLAKE2B 9fa57d50e382972bb50a3c54d71c2d74e44e5ec92f83baadf8115994fb58a82a513639ef6e05f314cffa96b595c96ad1210dc72130c1c655a55a47b4c9e103b3 SHA512 3c7f160f92610cc70fcd923374bcd955f1a8af395d2aa5f93ba970ae1778ba1a576df24cf0526627252ab1a2e7195d28d2f56a20c4d3292e890091f7ea34aaf9
MISC metadata.xml 351 BLAKE2B cf3c7f2e804dbe6ddce9380d9c7b32e734df16a04ea867a474a4e6868edfaa72abb79dd6eb47f67128a1b60cb4872c999949e8237102bc2117e581309307f862 SHA512 d32137e0b4549baf85ffaff35d2c5fb058a44e3fbeb7f560db3ebbfc1d44d9ce3651e033cb8434f211994218a85d5bf89f42ea9e3ab76e361c1014dcc6f25997
diff --git a/virtual/rust/rust-1.64.0-r1.ebuild b/virtual/rust/rust-1.64.0-r1.ebuild
new file mode 100644
index 000000000000..6b38ec4b8770
--- /dev/null
+++ b/virtual/rust/rust-1.64.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-14"
+#KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.65.0-r1.ebuild b/virtual/rust/rust-1.65.0-r1.ebuild
new file mode 100644
index 000000000000..8a0f09ded700
--- /dev/null
+++ b/virtual/rust/rust-1.65.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-15"
+#KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"