summaryrefslogtreecommitdiff
path: root/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild')
-rw-r--r--www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild b/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild
new file mode 100644
index 000000000000..284bedb2db25
--- /dev/null
+++ b/www-apache/mod_extract_forwarded/mod_extract_forwarded-2.0.3_pre2015052015.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit apache-module
+
+DESCRIPTION="Rewrites X-Forwarded-For to REMOTE_ADDR for reverse proxy configurations"
+HOMEPAGE="http://www.openinfo.co.uk/apache/index.html"
+#SRC_URI="http://www.openinfo.co.uk/apache/extract_forwarded-${PV}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~pacho/maintainer-needed/${P}.tar.xz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="mod_proxy"
+
+DEPEND=""
+RDEPEND="mod_proxy? ( www-servers/apache[apache2_modules_proxy_connect] )"
+
+APACHE2_MOD_CONF="98_${PN}"
+APACHE2_MOD_DEFINE="EXTRACT_FORWARDED"
+
+need_apache2_4
+
+src_prepare() {
+ if ! use mod_proxy; then
+ sed -i -e 's:#define USING_proxy_http_module .*::' mod_extract_forwarded.c || die
+ fi
+}