summaryrefslogtreecommitdiff
path: root/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
commit522fa4e6f267ba688a264ceec8d6c79663b61219 (patch)
tree67895f3a8243148309fbd841dabba28c37f4ed4a /www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild
parent32c16465e56b0122cf6e5a4625e9c7b56b107b07 (diff)
gentoo auto-resync : 08:10:2023 - 12:03:01
Diffstat (limited to 'www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild')
-rw-r--r--www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild b/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild
new file mode 100644
index 000000000000..b70dfc8ac59d
--- /dev/null
+++ b/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit apache-module
+
+MY_PV="1.0b1"
+DESCRIPTION="Apache module that processes X-SENDFILE headers registered by the output handler"
+HOMEPAGE="https://tn123.org/mod_xsendfile/"
+SRC_URI="https://tn123.org/mod_xsendfile/beta/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux"
+
+need_apache2
+
+src_install() {
+ APACHE2_MOD_CONF="50_${PN}"
+ APACHE2_MOD_DEFINE="XSENDFILE"
+ APACHE_MODULESDIR="/usr/$(get_libdir)/apache2/modules"
+
+ apache-module_src_install
+
+ dodoc docs/Readme.html
+}