summaryrefslogtreecommitdiff
path: root/www-apps/ampache/ampache-3.8.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /www-apps/ampache/ampache-3.8.8-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'www-apps/ampache/ampache-3.8.8-r1.ebuild')
-rw-r--r--www-apps/ampache/ampache-3.8.8-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/ampache/ampache-3.8.8-r1.ebuild b/www-apps/ampache/ampache-3.8.8-r1.ebuild
new file mode 100644
index 000000000000..1e494dd35081
--- /dev/null
+++ b/www-apps/ampache/ampache-3.8.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="PHP-based tool for managing,updating and playing audio files via a web interface"
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="https://github.com/ampache/ampache/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# Remove this and the SLOT line below if the code changes. Added for a dependency only change
+WEBAPP_MANUAL_SLOT="yes"
+SLOT="${PV}"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="aac flac mp3 ogg transcode"
+
+RDEPEND="dev-lang/php[gd,hash(+),iconv,mysql,pdo,session,unicode,xml,zlib]
+ transcode? ( media-sound/lame
+ aac? ( || ( media-libs/faad2 media-sound/alac_decoder ) )
+ flac? ( media-libs/flac )
+ mp3? ( media-sound/mp3splt )
+ ogg? ( media-sound/mp3splt media-sound/vorbis-tools )
+ )"
+DEPEND=""
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ doman docs/man/man1/ampache.1
+ rm -rf docs/man || die "Unable to remove local man dir"
+
+ dodoc docs/*
+ rm -rf docs/ || die "Unable to remove local docs dir"
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "Install and upgrade instructions can be found here:"
+ elog " /usr/share/doc/${P}/INSTALL.bz2"
+ elog " /usr/share/doc/${P}/MIGRATION.bz2"
+ webapp_pkg_postinst
+}